Support » Plugin: Cost of Goods for WooCommerce » Fatal error when activating plugin

  • Resolved dafaher

    (@dafaher)


    Hello guys, I was running some tests on Xampp (I’m developing my website in localhost first) and when I try to activate the plugin, it says:

    Fatal error: Namespace declaration statement has to be the very first statement or after any declare call in the script in ***/vendor/skyverge/wc-plugin-framework/woocommerce/class-sv-wc-plugin.php on line 26

    I did some research and that line says:

    namespace SkyVerge\WooCommerce\PluginFramework\v5_4_1;

    Any idea why this happens? I opened a support ticket but no reply yet, so I thought about asking the community for an opinion. Btw, I’m running WordPress latest version, all my plugins are updated and my PHP version is 7.4.

    Thanks in advance for any advice or suggestion!

    • This topic was modified 1 month, 4 weeks ago by dafaher.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @dafaher,

    Sorry for the late reply.

    Are you sure the error is related to our plugin? From what you’ve posted, it looks like it’s related to SkyVerge?

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @dafaher,

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – please let me know if you still have any questions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.