Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Warning: Creating default object from empty value in

  • Hi!

    i hope that someone can help. I used UM Version 1 for some time and just updated to UM 2.0.

    Unfortunately now my main menu is not showing up any more, instead theres an error in the frontend of my site saying:

    Warning: Creating default object from empty value in /www/htdocs/xxxxx/team.livelean.de/wp-includes/nav-menu-template.php on line 341

    I’ve already disabled my theme (using the theme osmosis) and switched to the default theme, but the error is still the same.

    Thank you in advance!

    Best,
    Kim

    • This topic was modified 1 year, 4 months ago by  kimlivianawp.
    • This topic was modified 1 year, 4 months ago by  kimlivianawp.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • I just experienced, that the menu is only disappearing when logged in into UM, if this helps in any way..

    Another experience i just had: if i change the settings of my menu items in the way that they are not restricted to logged in users but available to the public, the menu is showing!

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @kimlivianawp,

    Can you please try to do a conflict test by disabling all plugins except Ultimate member and see if this issue goes away. Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    Hi @ultimatemembersupport

    i already did a conflict test, issue is still the same.

    In this thread theres someone with the same issue, too.. https://wordpress.org/support/topic/conflict-with-google-maps-in-web-2-0-directory-plugin/

    Hope you can help.

    Best
    Kim

    just wanted to let you know, that i just installed the latest update (v2.0.9) and it seems like my problem is solved! 🙂

    2.0.9? I can only find up to 2.0.4

    I had the same issue with the missing menu replaced with the error, “Warning: Creating default object from empty value…”

    My solution was to click Ultimate Member > Misc > then check the ‘WP Menu Item Custom Fields Workaround’ option

    I do not know why this worked, but it did. I am using the twenty seventeen theme.

    I just updated from 2.0 to 2.04. Since update I get several errormessages in backend. Any ideas??

    SCREENSHOT: https://ibb.co/nBRnmc

    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 297
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 300
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 303
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 306
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 309
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 312
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 318
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 321
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 324
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 330
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 333
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 336
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 339
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 342
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 345
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 348
    Warning: Creating default object from empty value in /home/xxx/xxx/xxx/public_html/xxx/wp-content/plugins/ultimate-member/includes/class-init.php on line 351

    Hi Jereon,

    I guess your previous version of UM was a “pre 2.0 version”. So you have to follow the instructions “Manually updating to 2.0”: https://docs.ultimatemember.com/article/262-manually-updating-to-2-0

    Rgds,
    C.

    Hi Coxinha,

    I think you are right. I manually (FTP) overwrote current malfunctioning version 2.04 with 2.02. Then I updated in WP dashboard to 2.04 again. No more errors!

    Thanks for your help!

    I’m glad to hear that and that I could help you. 🙂

    I’m struggling with the same as written above!
    Where do I find an older version ala:
    https://wordpress.org/support/topic/conflict-with-google-maps-in-web-2-0-directory-plugin/

    which doesn’t exist there anymore.

    Rgds
    Geir A..

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Warning: Creating default object from empty value in’ is closed to new replies.