Support » Plugin: WP-PageNavi » fatal error when activating plugin

  • Hi scribu,

    When installing the wp-pagenavi i get the ‘fatal error’ message although I am running PHP5. When i downgraded to the 2.61 version of wp-pagenavi, i received a ‘Cannot redeclare wp_pagenavi() (previously declared in…’ error message. Any suggestions?

    thanks again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author scribu

    (@scribu)

    So you’re running WP 3.2.1, which requires PHP 5.2.4.

    Please post the entire error message in both cases.

    Yep using WP 3.2.1 with PHP 5.2. I can upgrade to 5.3?

    The code I get with the 2.61 version of wp-pagenavi is:

    Fatal error: Cannot redeclare wp_pagenavi() (previously declared in /home/sites/dannyboy.com/public_html/wp-content/themes/Video/library/functions/custom_functions.php:492) in /home/sites/dannyboy.com/public_html/wp-content/plugins/wp-pagenavi/wp-pagenavi.php on line 186

    If i take this custom function out however, I get:

    Plugin could not be activated because it triggered a fatal error.

    thanks,

    Plugin Author scribu

    (@scribu)

    Ok, so after removing the custom function from your theme, neither version of WP-PageNavi works?

    Does it work with the twentyeleven theme?

    same problem where is the mistake.does anybudy figureout problem

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘fatal error when activating plugin’ is closed to new replies.