Support » Plugin: WebP Converter for Media - Convert WebP & Optimize Images » Fatal error when activating (/app/Admin/Modal.php)

  • Resolved Andrews32

    (@andrews32)


    Parse error: syntax error, unexpected ‘?’ in /home/u/user/site.com/public_html/wp-content/plugins/webp-converter-for-media/app/Admin/Modal.php on line 20

    Plugin version: 2.2.0.
    WP version: 4.9.8.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @andrews32,

    Thanks for your message.

    What version of PHP are you using?

    Thread Starter Andrews32

    (@andrews32)

    Oh, so quickly! I`m very pleased.

    Just udated WP to latest.

    PHP was 5.6 until this minute (changed to 7.1, and the “Plugins” dashboard section became overloaded by PHP errors…

    First I have to fix all the other plugins bugs “at least adding “@”).

    But, your plugin shows some bus too (I cannot activate it right now – no “Activate” link, xoxo, just error messages):

    Warning: count(): Parameter must be an array or an object that implements Countable in /wp-admin/includes/class-wp-list-table.php on line 546

    Warning: Invalid argument supplied for foreach() in /wp-admin/includes/class-wp-list-table.php on line 562

    Thread Starter Andrews32

    (@andrews32)

    1st fatal error solved (“workaround” method. “crutch” in my language):

    public function showDeactivationModal(){
    //if(basename(($_SERVER[‘SCRIPT_FILENAME’] ?? ”), ‘.php’) !== ‘plugins’){return;}

    $basename = basename( ($_SERVER[‘SCRIPT_FILENAME’]), ‘.php’ );
    if($basename !== ‘plugins’){return;}

    But the next bug appeared:
    Parse error: syntax error, unexpected ‘?’ in /wp-content/plugins/webp-converter-for-media/app/Loader/Passthru.php on line 73

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Please install PHP version 7.0 or higher. The plugin does not support PHP 5.6.

    Thread Starter Andrews32

    (@andrews32)

    Thank you!

    To install PHP 7+, I have to fix too many other installed plugins bugs…

    I`d better find another Webp convert plugin.

    Closed ticket.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Just update them. Plugins should have been supporting PHP 7.0 for a long time.

    Metin

    (@granices)

    gave me the same error. php 7

    kylos90

    (@kylos90)

    I have the same error.
    WP version: 5.7
    Plugin version: 2.4.0
    PHP version: 7.4.15

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.