• Resolved diegooborges

    (@diegooborges)


    There was an update on the php version of the server and now I can not activate the plugin. Fatal error.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Andy Potanin

    (@andypotanin)

    Can you specify which version of PHP you have now that’s causing the error? Also, the OS and any other server details. Our servers run in PHP7 and we typically test between PHP 5.3 – 7.1, and have not had any fatal activation errors reported.

    The error log would help as well.

    diegooborges

    (@diegooborges)

    Info server:
    ast login: Tue Jul 25 08:37:34 2017 from 191.189.47.113
    root@host3 [~]# php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cli) (built: Jul 18 2017 00:58:22)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com v6.1.0 (), Copyright (c) 2002-2017, by ionCube Ltd.
    with Suhosin v0.9.38, Copyright (c) 2007-2015, by SektionEins GmbH
    root@host3 [~]# uname -a
    Linux host3.webservhost.com 2.6.32-696.299.3.2.cp6.x86_64 #1 SMP Tue Jun 20 17:32:23 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    root@host3 [~]# exit
    logout
    Connection to host3.brasilserv.com closed.

    diegooborges

    (@diegooborges)

    Do you need any more information? 🙂

    diegooborges

    (@diegooborges)

    About the error log, it does not exist because I can not activate the plugin.
    Can you help me?
    Help 🙂

    Plugin Contributor MariaKravchenko

    (@mariakravchenko)

    Hello.

    Can you enable debug in your wp-config.php file and try to activate the plugin. You should see the particular error.

    Also, a good practice is to deactivate all third party plugins and check again. Let me know how that goes.

    Regards.

    diegooborges

    (@diegooborges)

    Hello,

    The debug was already active.
    I’ve also tested it by disabling all other plugins.

    The error log is this:
    [02-Aug-2017 11:39:58 UTC] PHP Notice: wp_specialchars is obsolete </ strong> since version 2.8.0! Use esc_html () instead. In /home/rscorretor/public_html/wp-includes/functions.php on line 3831

    It’s the only mistake, and it’s weird because wordpress is up to date.

    Can you help me?
    If you need, I can pass the login and password of admin wp.

    Plugin Contributor MariaKravchenko

    (@mariakravchenko)

    You can send details using this form, I will check that directly on your site. – https://www.usabilitydynamics.com/contact-us

    Regards.

    diegooborges

    (@diegooborges)

    sent to you!

    Thanks!

    cramps

    (@cramps)

    I am getting this error when I try and edit/modify my page

    Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /homepages/42/d691631597/htdocs/app691632383/wp-includes/capabilities.php:539 Stack trace: #0 /homepages/42/d691631597/htdocs/app691632383/wp-includes/functions.php(2554): current_user_can(‘unfiltered_html’) #1 /homepages/42/d691631597/htdocs/app691632383/wp-includes/media.php(3331): get_allowed_mime_types() #2 /homepages/42/d691631597/htdocs/app691632383/wp-content/plugins/hrm-front-end/class/class.settings-api.php(48): wp_enqueue_media() #3 /homepages/42/d691631597/htdocs/app691632383/wp-content/plugins/hrm-front-end/class/class.settings-api.php(37): WeDevs_Settings_API->admin_enqueue_scripts() #4 /homepages/42/d691631597/htdocs/app691632383/wp-content/plugins/master-slider/admin/views/setting/class-msp-settings.php(19): WeDevs_Settings_API->__construct() #5 /homepages/42/d691631597/htdocs/app691632383/wp-content/plugins/master-slider/admin/views/setting/class-msp-settings.php(356): MSP_Settings->__construct() #6 /homepages/42/d691631597/ht in /homepages/42/d691631597/htdocs/app691632383/wp-includes/capabilities.php on line 539

    Can anyone help?

    Plugin Contributor MariaKravchenko

    (@mariakravchenko)

    Hello @cramps

    Please create another ticket to investigate your issue. Anyway, I do not see any relation to our plugin in that error. Which page do you try to9 modify? (Please answer in your own thread.)

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fatal Error when activate plugin.’ is closed to new replies.