Support » Plugin: WooCommerce » Fatal Error when accessing Woo admin pages

  • Resolved Stefan Pejcic

    (@stefanpejcic)


    When trying to access any Woo page on admin (settings, products, orders..) I get the following error:

    Fatal error: Uncaught RuntimeException: Error saving action: Unable to save action. in /public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_wpPostStore.php:33 Stack trace: #0 /public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_ActionFactory.php(109): ActionScheduler_wpPostStore->save_action(Object(ActionScheduler_Action)) #1 /public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_ActionFactory.php(59): ActionScheduler_ActionFactory->store(Object(ActionScheduler_Action)) #2 public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/functions.php(18): ActionScheduler_ActionFactory->single(‘woocommerce_upd…’, Array, 1576308113, ”) #3 /public_html/wp-content/plugins/woocommerce/includes/queue/class-wc-action-queue.php(44): as_schedule_single_action(1576308113, ‘woocommerce_upd…’, Array, ”) #4 in /public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_wpPostStore.php on line 33

    Any help is appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    Thanks for including the error text! It points to a problem with the action scheduler, but doesn’t really give much more information.

    This is likely caused by outdated plugins, given that we recently made some changes and gave the action scheduler a larger role – if plugins aren’t up to date, they could be causing errors like this. However, as you can’t access the dashboard to update, you can’t start there.

    I’d start by disabling all plugins via FTP:
    https://support.bestwebsoft.com/hc/en-us/articles/204301449-Deactivate-disable-Wordpress-plugin-via-FTP

    In this case, you could choose to rename the entire plugins folder, which will mean all plugins are disabled. At that point, try accessing your WordPress wp-admin – if it doesn’t work, then you know it’s something at server level and should contact your host.

    If it does work, I’d recommend updating all of the plugins and then activating them. You can try activating them all at once to see if the same error turns up – if so, you’ll need to deactivate the plugins again via FTP.

    I hope that helps you in the right direction!

    Hi Hannah, thank you for your reply.
    I’ve tried all of the above but I still have the same issue.

    I’ve also tried to deactivate all plugins and use the default theme, but I still have the same problem when entering wc admin area..
    I cant edit products, add new ones, etc.

    I’m really stuck here

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    It sounds like something is broken in your WordPress installation, if it doesn’t work at all when all plugins are disabled.

    From here, I’d recommend:

    1. Try reinstalling WordPress – the approach for this will differ based on your host’s setup
    2. Ask in the WordPress core support forum – they’ll have a better idea of what might be going on: https://wordpress.org/support/forum/how-to-and-troubleshooting/

    I did that already, I’ve noticed that when I empty all the wc tables in the database the error is gone. So it must have something to do with the database itself..

    I’ll open a topic on the core forum.
    thank you for your time Hannah!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal Error when accessing Woo admin pages’ is closed to new replies.