• Resolved Stefi007

    (@stefi007)


    Hi,

    Headers Security Advanced & HSTS WP Version: 5.0.22 – After installing the update, the following conflict occurs when using the WP install feature:

    Fatal error: Uncaught Error: call_user_func_array(): Argument #1 ($callback) must be a valid callback, function “hsts_plugin_remove_old_options” not found or invalid function name in …/wp-includes/class-wp-hook.php on line 310

    Call stack:

    WP_Hook::apply_filters()
    wp-includes/class-wp-hook.php:332
    WP_Hook::do_action()
    wp-includes/plugin.php:517
    do_action()
    wp-admin/includes/class-wp-upgrader.php:875
    WP_Upgrader::run()
    wp-admin/includes/class-theme-upgrader.php:250
    Theme_Upgrader::install()
    wp-admin/update.php:324
    Query Monitor

    P.S. Headers Security Advanced & HSTS WP Version: 5.0.21 that conflict did not appear.

    It also doesn’t help if uninstalling or deactivating the plugin and then re-updating to the final version 5.0.22.

    • This topic was modified 1 year ago by Stefi007.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Rimas

    (@erku)

    This was my mistake and I’m sorry for letting it slip. I’ve fixed it in Andrea’s private repo, and I hope he’ll release the fix soon.

    Marking this thread as resolved, let’s continue over at https://wordpress.org/support/topic/message-when-update-plugin/#post-16771887.

    Thread Starter Stefi007

    (@stefi007)

    Thank you for your quick response and fixing the 5.0.22 update bug that occurred. It didn’t pose any security risk, so I don’t think anyone had any particular problems.

    We are very grateful to your team for the excellent Headers Security Advanced & HSTS WP plugin. It’s really a very smart solution and very easy to use :). Thank you very much and good luck to your team for the future!

    The patched version 5.0.23 works great!

    • This reply was modified 1 year ago by Stefi007.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fatal error: Version 5.0.22 the following conflict occurs’ is closed to new replies.