Support » Plugin: Mailjet Email Newsletter Marketing » Fatal Error Upgrading to 5.0.2

  • Resolved christineyee

    (@christineyee)


    Hi there, upon upgrading to 5.0.2 on two of the sites I manage, the following error appeared and prevented the WP backend and frontend sites from loading:

    Parse error: syntax error, unexpected ‘const’ (T_CONST), expecting identifier (T_STRING) or \\ (T_NS_SEPARATOR) in /…/…/…/wp-content/plugins/mailjet-for-wordpress/src/includes/Mailjet.php on line 14

    I tried to downgrade back to 5.0.1 on one of the sites but the problem persisted. The plugin is currently deactivated so both sites are back up.

    http://www.thecrosshairsfoundation.org/
    http://www.8milevodka.com/

    Please let me know what I should try to get the plugin working again – thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mailjet

    (@mailjet)

    Hi, we will check this asap. I’ll let you know as soon as we discover something.

    Thanks! Let me know if there’s any other info I can provide to help.

    Plugin Author Mailjet

    (@mailjet)

    You can go back to the 4.4.1 version which shouldn’t cause this problem.
    It can be downloaded from here: https://wordpress.org/plugins/mailjet-for-wordpress/advanced/ at the bottom of the page, in the Previous Versions section.

    Plugin Author Mailjet

    (@mailjet)

    Hello again, the issue was caused by using an older PHP version ( PHP < 5.6). We’ve made modifications to support this version, so it should work fine for you now. Please download the new release of the plugin – v.5.0.3.

    Kind regards,
    Mailjet Plugins team

    Thanks very much! I upgraded to 5.0.3 on the affected sites and everything is working normally again. Appreciate the fast response!

    Plugin Author Mailjet

    (@mailjet)

    Thanks for your confirmation. Glad it works now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.