Support » Plugin: Amazon Associates Link Builder » Fatal error Update 1.8

  • Resolved fredel

    (@fredel)


    Hello,

    when i update to 1,8 i get this error

    Fatal error: Uncaught Error: Class ‘Aalb_Activator’ not found in /wp-content/plugins/amazon-associates-link-builder/amazon-associates-link-builder.php:66 Stack trace: #0 /wp-settings.php(305): include_once() #1 /wp-config.php(102): require_once(‘/kunden/470249_…’) #2 /wp-load.php(37): require_once(‘/kunden/470249_…’) #3 /wp-blog-header.php(13): require_once(‘…’) #4 /index.php(17): require(‘/kunden/470249_…’) #5 {main} thrown in/wp-content/plugins/amazon-associates-link-builder/amazon-associates-link-builder.php on line 66

    Do you have an idea?

    Best

    • This topic was modified 1 year, 3 months ago by  fredel.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @fredel,

    We will surely assist you. The line no. mentioned by you Line 66 in amazon-associates-link-builder.php does not even exist in v1.8.0. It seems to be some transient issue during update. Can you please try again updating the plugin and let us know if the error persists? If yes, please answer the following questions to help us to debug the issue:

    1. How are you updating the plugin? Are you using some other tool/plugin to update amazon-associates-link-builder(AALB)?
    2 Browser version on which you are facing the issue.
    3. Does the issue occur on all browsers or only a specific browser?
    4. PHP version (You can use plugins like display PHP version that display your PHP version on the WordPress dashboard)
    5. WordPress version
    6. Steps to reproduce the issue
    7. Any other PHP error logs during update and during use of plugin.
    8. List of plugins installed on your system
    9. Web server version(apache/nginx)
    10. From which plugin version are you updating to 1.8.0?
    11. Browser console log error (if any) generated at the time of the error. Steps to get the console logs:

    • Open the Console window in Chrome using Ctrl + Shift + J (or Cmd + Opt + J on Mac) Follow this for reference.
    • Hit the Save button and check the console log errors
    • Send us the screenshot of console log as it is by sharing them using any 3rd party image sharing tool.

    You can also send above details to link-builder-feedback@amazon.com

    Same error occurred for me as well when updated to the latest version. Website broke and I could not login to dashboard.
    I deleted the plugin from cpanel.

    I dont think this has anything to do with any other plugin but an issue in the latest update.

    Mine is the latest wordpress version, happens for all browsers, updated via the official dashboard update in wordpress.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear Users,

    We are not able to reproduce the same issue on our end. This might be a transient issue due to partial/incomplete update. Can you please try again updating the plugin(you can try on on your development stage) and let us know if the issue still persists.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear Users,

    Since we didn’t get any response from you, we hope that your problem is resolved. Please feel free to reopen the thread with details asked in the last comment in case of the issue still persists.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal error Update 1.8’ is closed to new replies.