Support » Plugin: Yoast SEO » Fatal error: Uncaught YoastSEO_Vendor

  • Resolved eventtvs

    (@eventtvs)


    Hello,

    I woke up today and tried to access the dashboard of my website and I was met with a Fatal Error, I’m not able to access it through backend nor Login.
    How can I solve this issue.

    Fatal error: Uncaught YoastSEO_Vendor\Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "Yoast\WP\SEO\Conditionals\Front_End_Inspector_Conditional". Did you mean one of these: "Yoast\WP\SEO\Conditionals\Addon_Installation_Conditional", "Yoast\WP\SEO\Conditionals\Admin\Licenses_Page_Conditional", "Yoast\WP\SEO\Conditionals\Admin\Post_Conditional", "Yoast\WP\SEO\Conditionals\Admin_Conditional", "Yoast\WP\SEO\Conditionals\Development_Conditional", "Yoast\WP\SEO\Conditionals\Front_End_Conditional", "Yoast\WP\SEO\Conditionals\Get_Request_Conditional", "Yoast\WP\SEO\Conditionals\Import_Tool_Selected_Conditional", "Yoast\WP\SEO\Conditionals\Jetpack_Conditional", "Yoast\WP\SEO\Conditionals\Migrations_Conditional", "Yoast\WP\SEO\Conditionals\New_Settings_Ui_Conditional", "Yoast\WP\SEO\Conditionals\News_Conditional", "Yoast\WP\SEO\Conditionals\No_Tool_Selected_Conditional", "Yoast\WP\SEO\Conditionals\Non_Multisite_Conditional", "Yoast\WP\SEO\Conditionals\Not_Admin_Aj in /home/customer/www/eventtia.com/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/symfony/dependency-injection/Container.php on line 307

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same here. Can’t login in backend and both site and backend throw a fatal error.
    Saw that Yoast has autoupdated today.
    Moved both the free and the premium version from plugins directory to a temporary directory and now the site is back online.

    Mark

    (@mark-bremmer)

    Same. Had to go into my Plesk dashboard to disable.

    Mark

    (@mark-bremmer)

    Update 19.5.1 has corrected the issue.

    I went from 19.4 to 19.5.1 and it still broke my site. I don’t think .5.1 fixed the entire issue. I never updated to 19.5. Went straight from 19.4 to 19.5.1.
    I have yoast, Yoast premium, and woo. all 3. First, one to try to update was regular yoast. All other plugins and WP on my site are current. Hope that helps to fix 19.5.1

    Glad I never trust autoupdate, Not a fan of paying anyone to be a beta tester. Yet this one still got me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.