Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Fatal error: Uncaught TypeError

  • Resolved radialyr

    (@radialyr)


    Hi,
    The front end of site appears to be fine. When hitting log in on mysite.org/wp-admin, there is a critical error, shown below (further visits to the site show the admin header, but attempting access of the dashboard also errors out). Is this something you recognize, and do you know how to resolve this?

    Fatal error: Uncaught TypeError: Argument 1 passed to Give\Onboarding\SettingsRepository::__construct() must be of the type array, bool given, called in /home/customer/www/mysite.org/public_html/wp-content/plugins/give/src/Onboarding/SettingsRepositoryFactory.php on line 23 and defined in /home/customer/www/mysite.org/public_html/wp-content/plugins/give/src/Onboarding/SettingsRepository.php:22 Stack trace: #0 /home/customer/www/mysite.org/public_html/wp-content/plugins/give/src/Onboarding/SettingsRepositoryFactory.php(23): Give\Onboarding\SettingsRepository->__construct(false, Object(Closure)) #1 /home/customer/www/mysite.org/public_html/wp-content/plugins/give/src/Onboarding/Wizard/Page.php(49): Give\Onboarding\SettingsRepositoryFactory->make(‘give_settings’) #2 [internal function]: Give\Onboarding\Wizard\Page->__construct(Object(Give\Onboarding\FormRepository), Object(Give\Onboarding\SettingsRepositoryFactory), Object(Give\Onboarding\LocaleCollection)) #3 /home/customer/www/mysite.org/public_htm in /home/customer/www/mysite.org/public_html/wp-content/plugins/give/src/Onboarding/SettingsRepository.php on line 22

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.