Support » Networking WordPress » Fatal error: Uncaught Error: Call to undefined function nocache_headers()

  • Hi, I tried to access my website today and received this instead:

    Fatal error: Uncaught Error: Call to undefined function nocache_headers() in /home/emmainge/public_html/wp-admin/admin.php:36 Stack trace: #0 /home/emmainge/public_html/wp-admin/index.php(10): require_once() #1 {main} thrown in /home/emmainge/public_html/wp-admin/admin.php on line 36

    I have tried to find a solution, but I am not completely savvy with everything so it is quite confusing. Im using this website for my class and hopefully need it running soon. Any help???

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • First, you shouldn’t see the error on your site, because you should not have WP_DEBUG on on production sites. But at least you can see why it is failing, and since it is failing in a way that indicates a core file is missing, then the solution is to reinstall manually.

    Thread Starter emmainge

    (@emmainge)

    Thank you Joy! okay I have downloaded the file. To deactivate plug-ins, I have gone into C-panel, deleted both wp-includes and wp-admin.

    I was trying to upload the new wp-includes and it keeps erring with “You must specify at least one file to upload”. Does this mean that I need to upload all files from wp-includes individually?

    Well, usually you indicate the folder to upload and it uploads the folder and everything in it. (so each file is individually uploaded)
    I find it easier to use the cPanel File Manager to upload the entire zip file, then select it and click on Extract. Then you know you have everything. Once extracted, you can move the wp-includes and wp-admin that were extracted to where they belong. And then you can delete the folder the extraction made, and the zip file also.

    Thread Starter emmainge

    (@emmainge)

    Ok so I have been using cPanel File Manager, but when I upload the zip file it still comes up with the same message.

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Howdy!

    My first question is have you used FileZilla to upload those files yet?

    The other question that first arose was: does this happen on both the admin and front-end of the site or just one?

    Have there been any changes since the last time you had visited the site? Sort of trying to build out a timeline of events to better understand and resolve this too 🙂

    I am also facing this same issue on my website qtoestimating.com. I reinstalled WordPress manually but after 1 to 2 hours, again fatal error comes. I also see that the wp-load.php file automatically gets 0kb size when this error comes. When I update the wp-load.php file with the content from WordPress site works fine. Then again the file gets corrupted. Please help.

    Is there a solution? It’s been 3 months

    Error is gone after setting read-only on wp-load.php

    naeemuddinn

    (@naeemuddinn)

    Hi @sergeyadm!

    How can I set up wp-load.php, please guide me I am also getting the same error.

    Sergey

    (@sergeyadm)

    Hi! You can try upload wordpress directory to your site.
    All directories must have 755 rules, for all files set 644 rules
    Also try to set read only atribute for wp-load.php

    Stef

    (@serafinnyc)

    @sergeyadm great find! Helped me out with a client. What if anything can be contributed to permissions on files being changed? I’ve never seen that before.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Fatal error: Uncaught Error: Call to undefined function nocache_headers()’ is closed to new replies.