• Resolved fjancsi85

    (@fjancsi85)


    Hi,

    I can’t login on the admin page. I didn’t claim anything, I just wanted to enter. I run a webshop, so this is a big problem and I need urgent help. I am subscribed to the All in One WP migration unlimited extension plugin. Can anyone help?

     

    Fatal error: Uncaught Error: Call to undefined function ai1wm_is_filesize_supported()
    in /home/petbuddy/public_html/wp-content/plugins/all-in-one-wp-migration/lib/model/class-ai1wm-backups.php on line 54

    Call stack:

    1. Ai1wm_Backups::get_files()
      wp-content/plugins/all-in-one-wp-migration/lib/model/class-ai1wm-backups.php:94
    2. Ai1wm_Backups::count_files()
      wp-content/plugins/all-in-one-wp-migration/lib/controller/class-ai1wm-main-controller.php:658
    3. Ai1wm_Main_Controller::admin_menu()
      wp-includes/class-wp-hook.php:308
    4. WP_Hook::apply_filters()
      wp-includes/class-wp-hook.php:332
    5. WP_Hook::do_action()
      wp-includes/plugin.php:517
    6. do_action()
      wp-admin/includes/menu.php:155
    7. require_once()
      wp-admin/menu.php:420
    8. require()
      wp-admin/admin.php:158
    9. require_once()
      wp-admin/index.php:10

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Yani

    (@yaniiliev)

    For premium products please reach over to our support team.
    Premium products are not supported on these forums.

    To fix the website, use FTP or file manager and rename wp-content/plugins/all-in-one-wp-migration to wp-content/plugins/all-in-one-wp-migration-disabled
    You can then delete the plugin and reinstall it.
    There is likely a much bigger major problem in your website than the plugin as it looks like some files are missing from your WordPress.

    Thread Starter fjancsi85

    (@fjancsi85)

    I just received a recovery link from wordpress. I turned off the Plugin and everything went back to normal. The problem is with the basic All-in-One WP plugin. The version number I use is 7.73.

    Plugin Author Yani

    (@yaniiliev)

    Uninstall the plugin, then install it again from the plugin repo. It should work right away. I’d be curious to find out what could have changed the plugin’s contents. There are no issues with 7.73 that we are aware of – this version has been out for almost a month.

    Thread Starter fjancsi85

    (@fjancsi85)

    Thank you, problem solved. I don’t know what could have happened either. But as I can see, someone else has opened a topic with the very similar error.

    The file wp-content/plugins/all-in-one-wp-migration/functions.php is currently being automatically deleted on all servers with Imunify360 as it’s being falsely detected as SMW-BLKH-2068114-php.bkdr.

    I’ve submitted a ticket to CloudLinux support team and they’ve escalated the issue.

    Once this is fixed, you can reinstall the plugin from CLI via the command:

    wp plugin install --force all-in-one-wp-migration --skip-plugins

    Plugin Author Yani

    (@yaniiliev)

    Thank you jasonabmw. I will try to reach out to Imunify360 and see if there is anything we can do on our side to resolve this faster.

    I’ve received a response regarding this issue including a temporary workaround (not posted here as I’m not sure this would be beneficial to users who are not experienced), and the message below:

    Let me assure you we are taking this matter seriously and are working diligently to resolve it. Our malware analysts have responded promptly and are in the process of delivering a new build with the problematic Blackhash excluded. We anticipate that this update will be available within the next several hours.
     
    Once the new build is released, files damaged will be restored automatically to ensure the smooth functioning of your websites.
     
    We appreciate your patience and understanding during this time. If you have any questions or concerns, please do not hesitate to reach us out. We are here to help and will keep you updated on our progress.

    Imunify Specialized Support | Senior Support Engineer
    Plugin Author Yani

    (@yaniiliev)

    Thank you for posting the update jasonabmw. It helps a lot!

    Hi, I’m experiencing this error in almost all my installations, few of them are ok.

    Also, I cannot find what is the difference between the installations giving error and the one staying.

    I confirm that deleting and installing again the plugin is recovering the error.

    Also, the problem is with the free plugin, no problems found with the unlimited and google drive extensions I’m using.

    —–

    Edit: In other installations deleting and reinstalling the plugin the error persists

    • This reply was modified 1 year, 1 month ago by David Cuesta. Reason: Correction
    Plugin Author Yani

    (@yaniiliev)

    I do not have a server with imunify360; it would be a great help if someone could try this build https://www.dropbox.com/s/sl60ig2dfn29kly/all-in-one-wp-migration.zip?dl=0 and see if imunify360 still deletes the file.
    I changed a few comments inside the file, nothing significant, but the checksum of the file is now different.

    I’ve received a confirmation that the Imunify360 signatures have been updated, and should already be rolling out to all servers.

    To force the update immediately, you can run the following command as the root user:

    imunify360-agent update sigs --force

    Once the signatures are updated, you can reinstall the plugin either by Plugins store, ZIP file, or by the following command as user (not root):

    wp plugin install --force all-in-one-wp-migration --skip-plugins

    In my testing on a few different servers, it no longer seems to be falsely detected and removed after this update.

    Plugin Author Yani

    (@yaniiliev)

    Jason,

    On behalf of the All-in-One WP Migration team, I’d like to extend our gratitude for your diligence in staying on top of the Imunify360 issue. Your efforts in keeping the community and developers informed and providing instructions for updating the signatures are truly commendable.

    You have helped many users in resolving this issue quickly and efficiently. We appreciate your awesomeness, and we are grateful to have community members like you supporting our plugin.

    Please don’t hesitate to reach out if you have any questions or concerns.

    Glad I could help!

    Hi @yaniiliev

    I’ve tested with the plugin version you provided here and can confirm that Imunify360 didn’t identify as a threat and didn’t delete or modified any files.

    🙂

    —-

    I don’t know if it’s useful now, but the previous version was getting this result in Imunify360:

    /public_html/wp-content/plugins/all-in-one-wp-migration/functions.php
    SMW-BLKH-2068114-php.bkdr

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Fatal error: Uncaught Error: Call to undefined function ai1wm_is_filesize’ is closed to new replies.