Support » Plugin: Event Tickets and Registration » Fatal error: Uncaught Error: Call to a member function is_built_with_elementor()

  • Resolved logichub

    (@logichub)


    After upgrading Event Tickets to 5.4.2, we are getting following error on the WordPress login page:

    Fatal error: Uncaught Error: Call to a member function is_built_with_elementor() on bool in /public_html/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php:36
    Stack trace:
    #0 /public_html/wp-includes/class-wp-hook.php(307): Tribe__Tickets__Editor__Compatibility__Tickets->include_frontend_form('')
    #1 /public_html/wp-includes/plugin.php(191): WP_Hook->apply_filters('', Array)
    #2 /public_html/wp-content/plugins/buddyboss-platform/bp-core/bp-core-catchuri.php(1535): apply_filters('the_content', '')
    #3 /public_html/wp-includes/class-wp-hook.php(307): bp_core_change_privacy_policy_link_on_private_network('', '')
    #4 /public_html/wp-includes/plugin.php in /public_html/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php on line 36

    Error went away if I remove following code from /public_html/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php:

    		if ( class_exists( '\Elementor\Plugin' ) && \Elementor\Plugin::$instance->documents->get( get_the_ID() )->is_built_with_elementor() ) {
    			return $content;
    		}

    Site’s system info is given below:

    Server: Apache
    MySQL: 5.7.32-35
    PHP: 7.4.30
    PHP Memory Limit: 768M
    WordPress: 6.0
    Theme: BuddyBoss Theme 2.0.5
    
    == Active Plugins ==
    Auto Login on Register for BuddyBoss 1.0.0
    BuddyBoss Platform 2.0.5
    BuddyBoss Platform Pro: 2.0.4
    Display Posts: 3.0.2
    Elementor: 3.6.7
    Elementor Pro: 3.7.2
    Events Tickets Extension: Virtual / Online Event Tickets: 1.1.1
    Event Tickets: 5.4.2
    Gravity Forms: 2.6.4
    Gravity Forms Polls Add-On: 3.9
    Gravity Forms Quiz Add-On: 3.9
    Gravity Forms reCAPTCHA Add-On: 1.1
    Gravity Forms Survey Add-On: 3.7
    Gravity Forms Twilio Add-On: 2.9
    Gravity Forms User Registration Add-On: 5.0
    Gravity Forms Webhooks Add-On: 1.5
    Gravity Forms Zapier Add-On: 4.2
    Health Check & Troubleshooting: 1.4.5
    If Menu - Visibility control for menus: 0.16.3
    Loggedin - Limit Active Logins: 1.3.1
    MemberPress + BuddyPress Integration: 1.1.16
    MemberPress AWS: 1.3.6
    MemberPress Cancel Override: 1.0.1
    MemberPress Courses: 1.1.8
    MemberPress Developer Tools: 1.2.11
    MemberPress Downloads: 1.1.6
    MemberPress Elementor Content Protection: 1.0.2
    MemberPress Importer: 1.6.8
    MemberPress Plus: 1.9.39
    SiteGround Security: 1.2.9
    Stream: 3.9.0
    The Events Calendar: 5.16.2.1
    The Events Calendar PRO: 5.14.3
    User Switching: 1.6.0
    User Switching in Admin Bar: 1.4
Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Support Abz

    (@abzlevelup)

    Hi @logichub, thanks for reaching out to us. Sorry to hear that you’re having this issue. Since you have an active license and for us to help you better, please open a Support Ticket on our Help Desk. It would also be great if you could copy and paste your System Information on the helpdesk ticket as well. We would like to investigate further of this issue.

    We look forward to helping you out with this one.

    Best,
    Abz

    Plugin Support Guga Alves

    (@gugaalves)

    Hi @logichub,

    We’re back with good news for you!

    We have just released the Event Tickets version 5.4.2.1, that fixes compatibility with Elementor-based themes and that fatal error using the is_built_with_elementor function.

    Please update your Event Tickets plugin to that recent release to apply that fix on your site.

    Best Regards!

    I have opened a support ticket as well, but in case someone sees it here first, this is still a major issue.

    PHP Fatal error: Uncaught Error: Call to a member function is_built_with_elementor() on bool in [redacted]/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php:39

    Stack trace:
    #0 [redacted]/wp-includes/class-wp-hook.php(307): Tribe__Tickets__Editor__Compatibility__Tickets->include_frontend_form(‘<div class=”tr…’)
    #1 [redacted]/wp-includes/plugin.php(191): WP_Hook->apply_filters(‘<div class=”tr…’, Array)
    #2 [redacted]/wp-includes/post-template.php(253): apply_filters(‘the_content’, ”)
    #3 [redacted]/wp-content/themes/astra/template-parts/content-page.php(54): the_content()
    #4 [redacted]/wp-includes/template.php(772): require(‘/home/…’)
    #5 [redacted]/wp-includes/template.php(716): load_template(‘…’, false, Array)
    #6 [redacted]/wp-includes/general-template.php(204): locate_template(Array, true, false, Array)
    #7 [redacted]/wp-content/themes/astra/inc/class-astra-loop.php(109): in [redacted]/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php on line 39`

    Plugin Support Abz

    (@abzlevelup)

    Hi @kylewhenderson, thanks for sharing and bringing this to our attention. I would need more information here for us to replicate the issue here.

    Could you provide the versions of the following?
    1. WordPress
    2. PHP
    3. Event Tickets Plugin
    4. Theme and Version

    We’d try to figure out common information for other users as well.

    Looking forward to hearing from you. I’d be glad to help you out with this one.

    Best,
    Abz

    IntegriTivity

    (@integritivity)

    I am on Event Tickets 5.4.3.1 and am having the same issue. If I disable it, I can log into WordPress again.

    1. WP 6.7.0
    2. PHP 7.3.33
    3. Event Tickets 5.4.3.1
    4. OceanWP

    Plugin Support Abz

    (@abzlevelup)

    Hi @integritivity, thanks for providing more information as well. This will definitely help us.

    In the meantime, could you try reverting back to the 5.4.2.2 version and see if that fixes the issue. Some of our customers are reverting back to this version, as a workaround.

    We’d notify this thread as soon as we know more.
    Have a great day.

    Best,
    Abz

    IntegriTivity

    (@integritivity)

    I reverted back to 5.4.2.1 but still had the same problem. I tried reverting back further to 5.3.2 but I am also using Event Tickets Pro and Events Calendar Pro and they are all on higher versions and won’t play with 5.3.2 any more.

    Is there a modification I can make to my tickets.php that will fix this for now?

    Plugin Support Abz

    (@abzlevelup)

    Hi @integritivity, thanks for trying it out, and sorry to hear about this. I reached out to our team and shared with me this snippet here:

    <?php
    //* Do NOT include the opening php tag
    
    add_filter( 'the_posts', 'tec_tickets_ar_page_themes', -5 );
    /**
     * Fix AR page when using some themes that mess up with the singular template.
     *
     * @param array $posts The list of posts.
     * @return array $posts.
     */
    function tec_tickets_ar_page_themes( $posts ) {
    	global $wp, $wp_query;
    
    	$template = tribe( 'tickets.attendee_registration.template' );
    
    	// Bail if we're not on the attendee info page.
    	if ( ! $template->is_on_ar_page() ) {
    		return $posts;
    	}
    
    	// Set as singular if using hello elementor.
    	$wp_query->is_singular = true;
    
    	return $posts;
    }

    See code reference here:
    https://gist.github.com/juanfra/45e13fbf18614e2669c8bd9a75a8503c

    You could try using a third-party Code Snippet plugin in implementing this https://wordpress.org/plugins/code-snippets/.

    Let me know how it goes on your end.

    Best,
    Abz

    IntegriTivity

    (@integritivity)

    I tried adding this to my functions.php but the admin login still had the same error.
    I also tried adding it to the tickets.php, to no avail.
    https://augusta-chamber.org/wp-login

    IntegriTivity

    (@integritivity)

    Elementor just came out with an update, should I run it?

    3.6.8 – 2022-07-27
    Fix: Align-self set to stretch is not working as expected in Container (#17052)
    Fix: Bad request error is being thrown when trying to import a template

    Plugin Support Abz

    (@abzlevelup)

    Hi @integritivity, I appreciate you trying the snippet and confirming that it didn’t work. I would inform the team about this.

    Regarding the Elementor Update, I recommend you test it on a staging site before updating just to be safe and keep a working backup of your entire website. See if that fixes the issue.

    Looking forward to hearing from you and let us know how it goes. This is helpful for us.

    Best,
    Abz

    IntegriTivity

    (@integritivity)

    A newer version of Elementor does not help. I actually have TWO websites experiencing the same issue: Event Tickets causes a Fatal Error which does not let an admin login: They are both using the OceanWP theme

    #3 …/public/wp-content/themes/oceanwp/partials/page/article.php(20): the_content() #4/public/wp-includes/template. in …/public/wp-content/plugins/event-tickets/src/Tribe/Editor/Compatibility/Tickets.php on line 39

    These are the versions I have tested
    Elementor 3.6.7 or 3.6.8
    Elementor Pro 3.7.2
    Event Tickets 5.4.2.1 or 5.4.3.1
    Event Tickets Plus 5.5.2

    Plugin Support Abz

    (@abzlevelup)

    Hi @integritivity, sorry to hear about this, and appreciate you testing it out and getting back to us with more information.

    Since you have an active license and for us to help you better, please open a Support Ticket on our Help Desk. This is for us to follow the WP guidelines with premium users with active licenses.

    Moreover, it would also be great if you could copy and paste your System Information on the helpdesk ticket as well. We would like to investigate further of this issue.

    We look forward to helping you out with this one.
    Thanks for your patience.

    Best,
    Abz

    FYI, we are getting the same error in our logs.

    We are on the latest Elementor, and the latest Tickets plugin.

    Events Tickets Plus 5.5.2
    Events Tickets 5.4.3.1

    We are having the same issue on one of our sites:

    Elementor 3.6.8
    Elementor Pro 3.7.3
    Event Tickets 5.4.3.1
    Event Tickets Plus 5.5.2

    Theme: JupiterX

    Users cannot get to the checkout page. They see an error reading:
    Call to a member function is_built_with_elementor() on bool

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.