Support » Plugin: Jetpack by WordPress.com » Fatal error: uncaught error

  • Resolved Blamedutchie

    (@blamedutchie)


    Immediately after updating JP to the most recent version

    Fatal error: Uncaught Error: Class 'Automattic\Jetpack\Connection\Client' not found in ../../../wp-content/plugins/jetpack/class.jetpack-ixr-client.php:38 Stack trace: #0 ../../../wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php(191): Jetpack_IXR_Client->query('jetpack.syncAct...', Array) #1 ../../../wp-includes/class-wp-hook.php(286): Jetpack_Sync_Actions::send_data(Array, 'deflate-json-ar...', 1562114221.9798, 'sync', 0.012880086898804, 0.03004002571106) #2 ../../../wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 ../../../wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(244): apply_filters('jetpack_sync_se...', Array, 'deflate-json-ar...', 1562114221.9798, 'sync', 0.012880086898804, 0.03004002571106) #4 /../../dom in ../../../wp-content/plugins/jetpack/class.jetpack-ixr-client.php on line 38

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Derek Smart

    (@dsmart)

    Hi! This likely was due to a sync process happening during the plugin update, and called a file that no longer includes the method.

    Are you still seeing the error? If so can you please try and delete/re-install Jetpack as it should solve the issue. Thank you

    I’m getting these notifications from site after site. Reinstalling isn’t a feasible option. And when I log into the sites there are no reported errors. Just emails coming to me as the technical admin for a lot of sites. This has been going on for over 5 hours as I write this.

    Plugin Author Derek Smart

    (@dsmart)

    Hi Michael,

    Are you getting the exact errors?

    > And when I log into the sites there are no reported errors.

    You can see your error logs by enabling some WP_DEBUG constants in your wp-config.php. More details here https://codex.wordpress.org/WP_DEBUG

    As always, feel free to reach out to our support with your site’s details and we’ll be happy to take a closer look with you https://jetpack.com/contact-support/

    Here is one (from an email). It’s the same message over and over again. Just a different domain/account each time. Are you suggesting there is additional information to be gained from activating Debug mode? The sites appear to be operating normally. They just send out these bizarre messages.

    Error Details
    =============
    An error of type E_ERROR was caused in line 38 of the file /home/[DOMAIN ACCOUNT]/public_html/wp-content/plugins/jetpack/class.jetpack-ixr-client.php. Error message: Uncaught Error: Class ‘Automattic\Jetpack\Connection\Client’ not found in /home/[DOMAIN ACCOUNT]/public_html/wp-content/plugins/jetpack/class.jetpack-ixr-client.php:38
    Stack trace:
    #0 /home/[DOMAIN ACCOUNT]/public_html/wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php(191): Jetpack_IXR_Client->query(‘jetpack.syncAct…’, Array)
    #1 /home/[DOMAIN ACCOUNT]/public_html/wp-includes/class-wp-hook.php(286): Jetpack_Sync_Actions::send_data(Array, ‘deflate-json-ar…’, 1562121616.5943, ‘sync’, 0.00073790550231934, 0.001906156539917)
    #2 /home/[DOMAIN ACCOUNT]/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array)
    #3 /home/[DOMAIN ACCOUNT]/public_html/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(244): apply_filters(‘jetpack_sync_se…’, Array, ‘deflate-json-ar…’, 1562121616.5943, ‘sync’, 0.00073790550231934, 0.001906156539917)
    #4 /home/[DOMAIN ACCOUNT]/public_html/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(124): Jetpack_Sync_Sender->do_sync_for_queue(Object(Jetpack

    I get those messages too.

    Plugin Support KokkieH

    (@kokkieh)

    It’s the same message over and over again. Just a different domain/account each time.

    So you’re only receiving it once per site? Or does the email repeat itself for the same site as well?

    As you’re redacting the domain from the error message you’re posting here we have no way to check the actual site(s), so please submit a support ticket as requested above if you’re not able to provide that info to us in a public forum.

    Are you suggesting there is additional information to be gained from activating Debug mode?

    There might be. There’s no way to know without checking, though.

    @spiros,

    Please try re-installing Jetpack as @dsmart suggested above. If you’re still getting the emails after doing that, please open a support ticket at https://jetpack.com/contact-support/?rel=support with a link to your site so we can take a closer look.

    I just saw the exact same error during upgrade, but only one of two WordPress installations. Here are more details about my case:

    * I have a test site (“site A”) that has been under development for a while, on my own server.
    * I recently copied this entire site to another host and domain, in preparation for go-live. Call that copy “site B”. I fixed it up manually by changing the config files and doing search-and-replace on links in the database. (I’m new to WordPress so it’s possible I missed something here — but everything seems to work fine.)
    * When I logged in to site B’s dashboard, it said Jetpack was in Safe Mode due to detecting a duplicate site (fine): I chose “Fix Jetpack’s Connection”, since site B is the new primary version that will some day be a live site.
    * I then upgraded site B, which indicated success but also displayed the exact error shown in this thread.
    * I then went back and logged into site A, got the same Jetpack Safe Mode message and this time chose to stay in safe mode (since site A is my old testing copy).
    * I updated site A and did *not* see any error.

    So I wonder if this error might relate to (i) Jetpack Safe Mode, or (ii) WordPress installations that have been created by copying an existing install and manually fixing things.

    Each site only sends the message once. I’ll submit a support ticket on one of the sites.

    In my situation none of these are test blogs. They are all live sites and most of them haven’t had any recent changes made to them other than to automatically install the latest plugin and theme updates. This is a problem with the Jetpack plugin and not with our sites.

    So here is an update. I looked in the WP error log file. There was nothing there that hasn’t already been reported here. Jetpack says it’s missing a class.

    I activated the DEBUG, LOG, and DISPLAY attributes via “wp-config.php”. I learned that 3 older plugins need to change their code or I will have to replace them but the original error was not triggered. After deactivating the plugins the WordPress Site Health report gave me a bizarre set of contradictory warnings (e.g. “You have X plugins and all are up to date” and “you have Z plugins and Y inactive plugins”). So the Site Health report isn’t reliable.

    All the sites use a plugin to automatically install plugin updates. This error has so far only been reported by a small number of them but the error messages are trickling in. I looked at a couple of sites that haven’t reported the error and they look fine. Everything is up-to-date. These sites use the same plugins as the site where I activated the DEBUG warnings above. These plugins don’t use “wp-cron.php” to schedule tasks.

    It looks to me like the Jetpack update process encounters an error. Something in the WP-Cron process triggers it. Everything seems to be functioning normally after the installation is completed. I manage too many sites to file support tickets for all of them when I have no other information to share. So I see no reason to file a support ticket for an issue I cannot replicate and which doesn’t seem to be happening with the consistency I feared.

    It could be there is a very obscure bug in Jetpack. It could also be that the servers are coming under intermittent heavy loads (rogue crawlers, DNS attacks, high volume traffic – lots of possible causes) and that whatever Jetpack is trying to do misfires because the servers cannot keep up.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Thanks for the write-up, we’ll see if we can track down what may have done that, but so far we just have the two of you here reporting it, so it could be hyper-specific to server configuration or anything else that happened around the same time as the update.

    The good news is, it only happens once and never again, my favorite type of bug. 🙂

    got the same error… just wanted to point out that my wordpress is in the older version since I have not updated the PHP version also…

    maybe those who are getting the error are in the older PHP version too…

    seeing this message in my dashboard – “Jetpack requires a more recent version of PHP and has been paused. Please update PHP to continue enjoying Jetpack.”

    All of our sites are running on PHP 7.2. I know 7.3 has been released but 7.2 is still considered “current”.

    @dsmart :

    Hi, I no longer see the error, but now I saw this (once), immediately after updating to Jetpack 7.5.2:

    Notice: Constant MEDIA_TRASH already defined in /../public_html/wp-config.php on line 95
    
    Notice: Constant WP_POST_REVISIONS already defined in /../public_html/wp-config.php on line 98

    I find it odd that Jetpack should set these options… Does it?

    Running JetPack on seven different sites, with seven different accounts, got the same error as previously mentioned on only three of them.

    These three sites do not share server space or a common host.

    Here’s an additional console error on *ONE* of these sites after updating (not sure it’s related):

    WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403
    g @ ?v=2.0:6

    • This reply was modified 4 months, 1 week ago by  lazykins. Reason: I was incorrect
Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.