WordPress.org

Support

Support » Plugins and Hacks » podPress » Fatal error – ugins/podpress/podpress_premium_functions.php)

Fatal error – ugins/podpress/podpress_premium_functions.php)

  • I added podpress. All seemed to be going well. When I went to set the general options I choose premium content as part of it. clicked update and now get:
    Warning: require_once(/home/advancedap/rechargeyourspark.com/wp-content/plugins/podpress/podpress_premium_functions.php) [function.require-once]: failed to open stream: No such file or directory in /home/advancedap/rechargeyourspark.com/wp-content/plugins/podpress/podpress.php on line 355

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/advancedap/rechargeyourspark.com/wp-content/plugins/podpress/podpress_premium_functions.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/advancedap/rechargeyourspark.com/wp-content/plugins/podpress/podpress.php on line 355

    —————-
    line 355 is require_once(ABSPATH.PLUGINDIR.’/podpress/podpress_premium_functions.php’);

    I then went back on the web to figure out what I missed. I saw a video that said I should add two files to where the rss2 directory is.

    I added
    the wp-atom.php and premiumcast.php and refreshed. this hasn’t resolved the problem.

    I’m using thesis wp theme

    Help thanks, Michele

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author ntm

    @ntm

    Hello Michele,

    thanks for posting the complete error message. It is very helpful and it says that the required file podpress_premium_functions.php which should be in the folder /wp-content/plugins/podpress/ is not in this folder (“[…] No such file or directory […]”).

    Maybe something went wrong during the installation process. Please, compare the file in that list http://plugins.trac.wordpress.org/browser/podpress/tags/8.8.9.2 with the files in your plugin folder. Maybe there are other files missing too.
    But you could also upload all the files via FTP.

    I saw a video that said I should add two files to where the rss2 directory is.

    Usually it is not necessary to copy the wp-atom.php or other files from a sub folder of the podpress folder to different location. Espacially copy the wp-atom.php file is only necessary if you are using a WP version which is older than WP 2.3. But using such an outdated WP version is really not recommendable.

    So make sure that all files of the plugin are in the wp-content/plugins/podpress folder.

    Regards,
    Tim

    Tim thanks for the shout out. When I reviewed the list I noticed that I was indeed missing some files. So I downloaded the plugin from WP org and used FTP to install.

    I replaced the wp-atom.php file with the original file from my blog. And I deleted the second file premiumcast.php

    I then tried to log in and am still getting the same error. I also cannot get to the site by typing in the url.
    line 355 is
    require_once(ABSPATH.PLUGINDIR.'/podpress/podpress_premium_functions.php');

    these are lines 353 – 358.

    /* stuff for premium podcasts */
    	if ( isset($podPress->settings['enablePremiumContent']) AND TRUE === $podPress->settings['enablePremiumContent'] ) {
    		require_once(ABSPATH.PLUGINDIR.'/podpress/podpress_premium_functions.php');
    		podPress_checkmem('premium functions included');
    		add_action('wp_login', 'podpress_adddigestauth');
    	}

    I searched all the files are can’t seem to find any file called
    podpress_premium_functions.php

    should this be changed?

    Any other ideas? It’s really appreciated

    [Please post code snippets between backticks or use the code button.]

    Plugin Author ntm

    @ntm

    The file is still not there: http://rechargeyourspark.com/wp-content/plugins/podpress/.

    If you can see the file via FTP then control the permissions of the files (they should be 0644).

    Rename (via FTP) the the podpress.php file e.g. to _podpress.php. That will deactivate the plugin and you can login again.

    Regards,
    Tim

    0644 for which files?

    Plugin Author ntm

    @ntm

    For all files in the podpress/ folder.

    Plugin Author ntm

    @ntm

    BTW: change the name of the _podpress.php file back to podpress.php after the plugin has been deactivated.

    Tim, thanks for your help.

    the 0644 didn’t help that I could see.

    I ended up deleting the entire plug in and adding a “_” in front of the shell files due to issues that sprang up when I downloaded again. Finally adding the newest version (again). I just activated it. I haven’t gone back through the settings yet. And I”m calling it good because the blog is back up. woo hoo.

    Michele – have a good one!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal error – ugins/podpress/podpress_premium_functions.php)’ is closed to new replies.
Skip to toolbar