WordPress.org

Support

Support » Themes and Templates » Fatal error. the update??

Fatal error. the update??

  • Fatal error: Class ‘WC_API’ not found in /home/goodstoc/goodstock.com.ua/i/wp-content/plugins/woocommerce/woocommerce.php on line 142

    update WP to 2.0.0.1 or 2 (I forgot to)

    can’t go into the admin panel and on

    what to do? don’t be updated??

Viewing 15 replies - 1 through 15 (of 16 total)
  • woocommerce, Mystile

    updated woocommerce, and now Fatal error…

    This function requires PHP 5.1.2 minimum.

    Can you check with your host which version you are using?

    I have the same exact problem.

    Fatal error: Class ‘WC_API’ not found in D:\Hosting\10541710\html\wp-content\plugins\woocommerce\woocommerce.php on line 142

    I am running with godaddy as my host and using PHP Version 5.3

    Do you have any WooCommerce extensions installed?

    only plugins that are activated are WooCommerce and 404 Redirected

    I have the exact same error. First time using woocommerce, Godaddy hosting. I’m seeing scattered reports of this error on the web,but no solutions yet. 2.0.3 did not fix.

    store.gardelco.com

    Same problem also godaddy hosting php 5.3.6 theme Hustle. If the solution really is just switching hosting that’s fine, some pointers would be appreciated. Some directions on how to reinstall the old version could also be a nice temporary fix.

    Im having the same problem with Godaddy and WooCommerce. I will give up.

    Spent the intire day trying to fix the problem, called 3 times to Goddady and its not working at all.

    I wish i could set up the free version of WooCommerce, find out how it work as a test and then set up it more professionaly with a good version of a template.

    if someone find how to fix the problem and want to help me, [Contact details redacted – You can find that level of support by hiring someone]

    Thank you

    I asked godaddy to switch to linux hosting they said 1-3 days done in 5 hours. Anywase much better not sure if its solved yet but it at least works most of the time and much faster. I will update tomorrow after more trials.

    let us know if it works and how to do that! :]

    Me to… this fatal error is killing me right now..

    Yes it did work, haven’t seen error sense. And it’s pretty simple just call Godaddy and ask to switch to Linux hosting no extra cost.

    COOOL.. I will call them in the morning

    Has anyone else figured out a solution to this besides telling GoDaddy to switch to Linux hosting?

    Is the issue linked with GoDaddy Servers? We are getting the error as well, and Godaddy is also our host.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Fatal error. the update??’ is closed to new replies.