Support » Plugin: WP Mail SMTP by WPForms » Fatal Error Spark Post

  • Resolved moritz0grammer

    (@moritz0grammer)


    Hello
    I have a Problem with all plugin related sites. If I open for example the WP SMTP Settings page I get following fatal Error:
    Uncaught ValueError: Unknown format specifier ” ” in /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Providers/SparkPost/Options.php:44
    Stack trace:
    #0 /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Providers/SparkPost/Options.php(44): sprintf()
    #1 /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Providers/Loader.php(199): WPMailSMTP\Providers\SparkPost\Options->__construct()
    #2 /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Providers/Loader.php(102): WPMailSMTP\Providers\Loader->get_entity()
    #3 /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Providers/Loader.php(223): WPMailSMTP\Providers\Loader->get_options()
    #4 /data/web/e129695/html/wp1/wp-content/plugins/wp-mail-smtp/src/Admin/Area.php(473): WPMailSMTP\Providers\Loader->get_supports_all()
    #5 /data/web/e129695/html/wp1/wp-includes/class-wp-hook.php(303): WPMailSMTP\Admin\Area->enqueue_assets()
    #6 /data/web/e129695/html/wp1/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters()
    #7 /data/web/e129695/html/wp1/wp-includes/plugin.php(470): WP_Hook->do_action()
    #8 /data/web/e129695/html/wp1/wp-admin/admin-header.php(102): do_action()
    #9 /data/web/e129695/html/wp1/wp-admin/admin.php(239): require_once(‘/data/web/e1296…’)
    #10 {main}
     thrown

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi @moritz0grammer,

    this is a strange issue. What version of PHP are you using?

    I just re-tested this with PHP 8.0.8 and 8.1 and the plugin settings open just fine, even when I select SpartPost mailer. No fatal error is produced.

    Are you using the SpartPost mailer? Did you recently update the PHP version?

    You can also try to reinstall the plugin and see if that will resolve the issue.

    Take care!

    Thread Starter moritz0grammer

    (@moritz0grammer)

    I am using Php 8.0 and I am not using the SpartPost mailer. I am using the custom Mail Server provided by my hosting provider and I haven’t touched the PHP settings for a while now. I already reinstalled the plugin but it didn’t resolve the issue. The only thing I did in the last couple of weeks was experimenting with Cache Plugins. I have W3 Cache installed but even when i deactivate all the newly added plugins i get the same Error.

    Thread Starter moritz0grammer

    (@moritz0grammer)

    Sadly i can’t give you the debug information from your debug tool because it also crashes.
    Thank you for your quick answer and have a nice day!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @moritz0grammer,

    are you may be using a non-english language on your WP site? Which language is it?

    Maybe our plugin is also translated to that language? That could mean that the translated string is not using the correct sprintf parameters and is causing this issue.

    Take care!

    Thread Starter moritz0grammer

    (@moritz0grammer)

    Hi
    yes I am using the german version of wordpress. The Plugin is also translated to German. At least the menu is.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @moritz0grammer,

    I found the issue. The percentage sign was not “escaped” properly and it causes this issue.

    @robertskiba, sorry to bother you again with a translation issue. I fixed a string in (development and stable branch) for the WP Mail SMTP plugin. Could you please accept them as correct translations?

    https://translate.wordpress.org/projects/wp-plugins/wp-mail-smtp/stable/de/default/?filters%5Btranslated%5D=yes&filters%5Bstatus%5D=waiting

    The issue was in the percentage sign ‘%’ if used in sprintf function it has to be escaped with another character, like so ‘%%’. That’s why the original string also has two percentage characters in it (it’s not a mistake).

    Thank you!

    Done ✅

    Plugin Author Gregor Capuder

    (@capuderg)

    @robertskiba Thank you very much!

    Are these translation updates automatically updated for the user’s WP site? Or what is the best way to update the translation files in this case?

    Take care!

    It needs some minutes or hours and then they will update automatically depending on your settings. But if you can’t wait, just exchange the mo file

    Thread Starter moritz0grammer

    (@moritz0grammer)

    Thank you! Now everything works just fine!

    Thread Starter moritz0grammer

    (@moritz0grammer)

    ..

    Plugin Author Gregor Capuder

    (@capuderg)

    Thank you @robertskiba for everything!

    And thanks @moritz0grammer for reporting the issue and confirming it’s resolved.

    Have a nice weekend! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.