Support » Plugin: Strong Testimonials » Fatal error settings.php on line 221

  • Resolved vfp7

    (@vfp7)


    Does not allow to save changes to plug-in “Strong Testimonials” settings on the “Form” tab:

    ../edit.php?post_type=wpm-testimonial&page=testimonial-settings&tab=form

    press <SAVE>

    Fatal error: Call to undefined function filter_var() in /home/site/site.com/docs/wp-content/plugins/strong-testimonials/admin/settings.php on line 221

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Chris Dillon

    (@cdillon27)

    What version of PHP are you on?

    Thread Starter vfp7

    (@vfp7)

    5.3

    Plugin Contributor Chris Dillon

    (@cdillon27)

    filter_var is a PHP function available in version 5.2+
    http://php.net/manual/en/function.filter-var.php

    I cannot imagine a reason why that would fail but I will consider removing it.

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Who’s your web host? Would you mind asking them if they have any idea why that native PHP function would not work on their server?

    Thread Starter vfp7

    (@vfp7)

    nic.ru

    Plugin Contributor Chris Dillon

    (@cdillon27)

    They advertise PHP 5.1 to 5.6 here:
    https://www.nic.ru/dns/service/hosting/index.html#answer5

    So we need a definite confirmation that your server is running at least PHP 5.2, the minimum version required by WordPress.

    Thread Starter vfp7

    (@vfp7)

    phpinfo():

    
    PHP Version 5.3.29
    
    System 	Linux alfpl.nichost.ru 4.4.0-77-generic #98-Ubuntu SMP Wed Apr 26 08:34:02 UTC 2017 x86_64
    Build Date 	Sep 28 2016 18:37:56
    Configure Command 	'./configure' '--with-layout=GNU' '--prefix=/usr/local/php53' '--sysconfdir=/etc/php/5.3' '--with-config-file-path=/etc/php/5.3' '--with-config-file-scan-dir=/etc/php/5.3/conf.d' '--enable-libxml' '--enable-mysqlnd' '--with-apxs2=/usr/bin/apxs' '--with-zlib-dir=/usr' '--disable-all'
    Server API 	Apache 2.0 Handler
    Virtual Directory Support 	disabled
    Configuration File (php.ini) Path 	/etc/php/5.3
    Loaded Configuration File 	/etc/php/5.3/php.ini
    Scan this dir for additional .ini files 	/etc/php/5.3/conf.d
    Additional .ini files parsed 	(none)
    PHP API 	20090626
    PHP Extension 	20090626
    Zend Extension 	220090626
    Zend Extension Build 	API220090626,NTS
    PHP Extension Build 	API20090626,NTS
    Debug Build 	no
    Thread Safety 	disabled
    Zend Memory Manager 	enabled
    Zend Multibyte Support 	disabled
    IPv6 Support 	enabled
    Registered PHP Streams 	compress.zlib, php, file, glob, data, http, ftp, https, ftps, zip
    Registered Stream Socket Transports 	tcp, udp, unix, udg, ssl, sslv3, tls
    Registered Stream Filters 	zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, convert.iconv.*
    ...
     
    Thread Starter vfp7

    (@vfp7)

    Thread Starter vfp7

    (@vfp7)

    Thank you all, the answer came from hosting support:

    In this case, you need to connect the PHP filter extension.
    You can connect the extension through the hosting control panel:
    – log in to the control panel (https://hosting.nic.ru), using your contract number and password;
    – go to the section “Web server” – “Manage modules”;
    – Click on the link “PHP (configure the module);
    – in the “PHP module extensions” block, click the “Manage extensions” link;
    – Select the checkbox “Show all extensions”;
    – Find the desired extension in the list that opens, check its box and save the changes.

    Plugin Contributor Chris Dillon

    (@cdillon27)

    I’m glad you got it working. I wasn’t aware that could be disabled. Thanks for sharing the solution.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fatal error settings.php on line 221’ is closed to new replies.