Support » Plugin: YITH WooCommerce Gift Cards » Fatal Error: Require File

  • Resolved Howdy_McGee

    (@howdy_mcgee)


    Hello,

    I’m getting the following Fatal Error when updating or installing a fresh copy of this plugin:

    Fatal error: require_once(): Failed opening required 'wp-content\plugins\yith-woocommerce-gift-cards/includes/class-yith-woocommerce-gift-cards.php'

    It looks like the YITH_YWGC_DIR constant holds onto the plugin’s root directory of the plugin but the class-yith-woocommerce-gift-cards.php file is in a lib directory. The root functions.php requires seem to be 1 directory off.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter Howdy_McGee

    (@howdy_mcgee)

    The latest update seems to have fixed this. Thanks for pushing it so quickly!

    scookmb

    (@scookmb)

    The latest update as in 3.15 or is there one later? The most recent update caused PayPal Express to fail and sent multiple errors when trying to checkout. Not just buying a gift card, but for any purchase with the Yith Gift Card installed, PayPall does not work. I disabled the gift Card plug-in and now PayPal is working. You may want to check to make sure your checkouts are not being affected.

    Given the gift card plugin is disabled, any idea when a new fix will be released?

    Thread Starter Howdy_McGee

    (@howdy_mcgee)

    @scookmb I’m not the plugin developer. 2.10.0 fixed my issue. If you have a separate issue I’d recommend creating a new topic.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.