Support » Plugin: Keyring » 'Fatal error' preventing installation

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Beau Lebens

    (@beaulebens)

    Can you please check your server’s error logs and see what the full error is? That appears to be cut off (should include a line number and full function name).

    Thanks

    Thanks, it’s:

    Parse error: syntax error, unexpected T_FUNCTION in /home/consider/public_html/wp-content/plugins/keyring/keyring.php on line 48

    Plugin Author Beau Lebens

    (@beaulebens)

    Interesting. That’s the first line where a closure/anonymous function is used. PHP claims to support them in PHP 5.3.

    Does your web host have an option to run a more recent version of PHP? PHP 5.4+?

    Thanks Beau, changing it to 5.4 fixed it, didn’t realise I could upgrade manually.

    Plugin Author Beau Lebens

    (@beaulebens)

    Good to know, thanks for the update. Maybe I’ll just bump up the minimum requirements to avoid confusion 🙂

    Hello,
    I got the same error but on line 50. Can you help?

    Plugin Author Beau Lebens

    (@beaulebens)

    @gdillonmuurphy: if you’re getting that error, it’s because you’re using an outdated version of PHP. You’ll need to upgrade the version of PHP you’re using, which you can normally do through some sort of option/setting with your webhost (or by contacting them and asking them to do it for you).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘'Fatal error' preventing installation’ is closed to new replies.