WordPress.org

Forums

Instapress
[resolved] Fatal Error [Plugin Instapress] Version 1.3.1 (7 posts)

  1. angeal
    Member
    Posted 3 years ago #

    everytime i try to connect with my instagram-account i receive following errormessage:

    Fatal error: Uncaught exception 'Zend_Http_Client_Adapter_Exception' with message 'Unable to Connect to ssl://api.instagram.com:443. Error #164047936: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?' in /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/instagram-php-api/Zend/Http/Client/Adapter/Socket.php:235 Stack trace: #0 /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/instagram-php-api/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('api.instagram.c...', 443, true) #1 /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/instagram-php-api/Instagram.php(123): Zend_Http_Client->request() #2 /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/classes/Instagram_XAuth.php(24): Instagram->_getHttpClientResponse() #3 /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/instagram.php(660): Instagram_XAuth->getAccessToken('') #4 [internal function]: InstagramPlugin->handleOptions('' in /mnt/webb/61/99/52169199/htdocs/blog/wp-content/plugins/instapress/instagram-php-api/Zend/Http/Client/Adapter/Socket.php on line 235

    can someone help me?

    http://wordpress.org/extend/plugins/instapress/

  2. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    this is because you need to activate OpenSSL on your server to interact with the Instagram API. Please activate OpenSSL or contact your provider:
    http://www.nowfromhome.com/activate-openssl-extension-in-php/

    If you need any further help just let me know :)

  3. foochuck
    Member
    Posted 3 years ago #

    I'm having the same problem. I can't find the openssl line in my php.ini to uncomment...

  4. foochuck
    Member
    Posted 3 years ago #

    Nevermind that, I found the solution and now instapress works! :)

  5. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    could you tell us how you solved that issue? Thanks.

  6. foochuck
    Member
    Posted 3 years ago #

    @tkrammer,

    I used this link:

    http://www.leoganda.net/how-to-enable-xampp-ssl-socket-transport/

    Please note that my php.ini didn't have the following line in it:

    ;extension=php_openssl.dll

    So I added the following to the dynamic extensions section of php.ini:

    extension=php_openssl.dll

    And that worked.

  7. garguilo
    Member
    Posted 3 years ago #

    Thank you! I will ask my host (since this host sucks and i see no way to do it myself) to turn on OpenSLL. Hopefully that works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Instapress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags