Support » Plugin: Advanced uploader » Fatal Error – PHP8 Incompatible

  • Hello.

    Getting the following error/stack trace when uploading files on a bare wordpress install, running PHP 8.0

    [18-Mar-2021 17:10:37 UTC] PHP Fatal error: Uncaught TypeError: implode(): Argument #2 ($array) must be of type ?array, string given in wp-content/plugins/advanced-uploader/upload.php:982
    Stack trace:
    #0 wp-content/plugins/advanced-uploader/upload.php(982): implode()
    #1 wp-includes/class-wp-hook.php(292): advupl_attachment_fields_to_edit()
    #2 wp-includes/plugin.php(212): WP_Hook->apply_filters()
    #3 wp-admin/includes/media.php(1925): apply_filters()
    #4 wp-includes/media.php(4116): get_compat_media_markup()
    #5 [internal function]: wp_prepare_attachment_for_js()
    #6 wp-admin/includes/ajax-actions.php(2993): array_map()
    #7 wp-includes/class-wp-hook.php(292): wp_ajax_query_attachments()
    #8 wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters()
    #9 wp-includes/plugin.php(484): WP_Hook->do_action()
    #10 wp-admin/admin-ajax.php(187): do_action()
    #11 {main}
    thrown in wp-content/plugins/advanced-uploader/upload.php on line 982

    Kind Regards
    – Allan

    • This topic was modified 10 months, 1 week ago by rehhoff.
  • The topic ‘Fatal Error – PHP8 Incompatible’ is closed to new replies.