Support » Plugin: Font Awesome » Fatal Error – Parse Error in class-fontawesome.php

  • Resolved nhwp

    (@nhwp)


    We received this error recently which resulted in deactivation of Font Awesome plugin.

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in ***/wp-content/plugins/font-awesome/includes/class-fontawesome.php on line 116

    We are running WP 4.9.8 in multi site mode. Same issue arises when trying to activate on any site.

    Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author mlwilkerson

    (@mlwilkerson)

    I saw this error once before and it was due to an out-dated version of PHP.

    We’ve recently replaced the old plugin here with a re-written one, which supports PHP 5.6 or later. PHP.net shows that they discontinued support for PHP versions prior to 5.6 back in 2016, and actually discontinued support for 5.6 just this month.

    Could you check the version of PHP that your site is running on? It may need to be updated to a current version.

    nhwp

    (@nhwp)

    Yeah, I wondered about that after posting here too, actually. The site is running on PHP 5.4.45.

    We adopted the site from a previous developer and I’ve asked their host to upgrade PHP. Thanks for the insight!

    Updating to latest PHP version worked for us also, now on 7.2 version.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.