Support » Plugin: WebP Express » Fatal error | Pageload

  • basvandijkk

    (@basvandijkk)


    Having the following error right after having changed the Nginx conf file.

    [07-Mar-2019 11:27:44 UTC] PHP Fatal error: Uncaught Error: Call to a member function find() on bool in /var/www/domains/dyflexis.dev01.webwhales.nl/domain/public_html/wp-content/plugins/webp-express/vendor/rosell-dk/dom-util-for-webp/src/ImageUrlReplacer.php:161
    Stack trace:
    #0 /var/www/domains/dyflexis.dev01.webwhales.nl/domain/public_html/wp-content/plugins/webp-express/vendor/rosell-dk/dom-util-for-webp/src/ImageUrlReplacer.php(200): DOMUtilForWebP\ImageUrlReplacer->replaceHtml(‘<!DOCTYPE html>…’)
    #1 /var/www/domains/dyflexis.dev01.webwhales.nl/domain/public_html/wp-content/plugins/webp-express/lib/classes/AlterHtmlInit.php(57): DOMUtilForWebP\ImageUrlReplacer::replace(‘<!DOCTYPE html>…’)
    #2 [internal function]: WebPExpress\AlterHtmlInit::alterHtml(‘<!DOCTYPE html>…’, 9)
    #3 {main}
    thrown in /var/www/domains/dyflexis.dev01.webwhales.nl/domain/public_html/wp-content/plugins/webp-express/vendor/rosell-dk/dom-util-for-webp/src/ImageUrlReplacer.php on line 161

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author rosell.dk

    (@roselldk)

    Thanks.

    It is already reported and fixed, but the bug-fix has not been released yet. It happens for very big HTML documents (> 600 kb). It does not happen when “picture” tag syntax is choosen.

    Thread Starter basvandijkk

    (@basvandijkk)

    Okay so for checking whether the plugin works out for my site I should just use picture instead for now. And before going live with it, switch back to my current settings(after having used the bug-fix patch).

    Btw probs for the quick response!!

    Plugin Author rosell.dk

    (@roselldk)

    Yes.
    And thanks 🙂

    Plugin Author rosell.dk

    (@roselldk)

    Just published the bugfix (0.12.1)

    Thread Starter basvandijkk

    (@basvandijkk)

    Nice! @roselldk great work man!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error | Pageload’ is closed to new replies.