Support » Fixing WordPress » Fatal error: Out of memory?

  • Last week I started getting this error for the first time…

    Fatal error: Out of memory (allocated 64487424) (tried to allocate 5567553 bytes) in /home/.undisclosed/username/ on line 173

    This comes up when I try to do any editing of existing posts, when I try to save a new draft, and even when I try to moderate spam or edit one of my own comments.

    I have no idea what it really means or how to fix it, so I Googled it. I’ve only been able to find minimal info and nothing that really helps to solve the problem. Has anyone come across this? I thought maybe I had too many plugins (17) running, so I disabled about half but it didn’t make a difference. I’m also running the latest version (2.2.1).

    My blog is only about 4months old, so in comparison to those who have been blogging forever, I fail to see how my DB could possibly be out of memory! I’m a beginner when it comes to databases, so any help is appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Fortunately, it’s a PHP issue, not a db issue.

    PHP is configured with a maximum amount of memory to use. Your host may be able to give you more, otherwise you’ll need to be a bit more scientific about your plugins.

    Disabling *some* won’t really help you troubleshoot as different plugins use different amounts of memory (and some older versions of popular ones are notorious for using LOTS of memory).

    Disable them all. Same problem?

    If that fixed it, enable one by one, testing along the way.

    Thank you, I’ll give it a try. I’ve been in touch with my host several times throughout the day, and they mentioned an upgrade of PHP and something about updating a php.ini config file for me. It didn’t make a difference. The staffer I’ve been in contact with also said

    “The primary issue here is something in this configuration of wordpress is allocating 65Megs then trying to allocate an additional
    55Megs of memory!”

    Not sure how he knows that, or what I can do about it. We tried commenting out the portion of code throwing the error, and it seemed to fix one issue but of course it just caused another one.

    He knows that based on your error message.

    Falling back to my earlier reply, have you tried disabling ALL plugins yet?

    Sorry about the delayed response… my host updated my apache service last week, and everything was working fine until this afternoon when the error cam up again. I am taking your advice and disabling everything. I’ve also put another ticket into the host, but I doubt they’ll be able to help any further. One of the techs recommended a fresh install. <cries>

    I get that same error all the time now. Running on WP 2.2.3. It cant be a plugin, as I never had any problem like this before…

    I got this message using the flexible uploader plugin. It wants to upload a large image and then resize it, and adding a watermark.

    I was hoping for an easy way for users not to have to know too much about images, but I guess this is not going to be an option!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error: Out of memory?’ is closed to new replies.