[resolved] Fatal error: Out of memory (on install, and php is set to a 256M!) (8 posts)

  1. kythin
    Posted 5 years ago #

    Hiya everyone,

    I'm trying to do an install on my new Rackspace server (with WHM on it), but I keep getting the infamous Fatal error: Out of memory problem.

    I have root access and have thus been able to change the main php.ini, which I've taken from 32M all the way to currently sitting on 256M and that number is verified with a phpinfo();.

    memory_limit 256M

    So I'm thinking it has to be some other configuration option that I missed when setting up WHM? I've recompiled Apache multiple times, trying PHP 5.2.6, 5.2.17, and 5.3.8.

    It seems to be breaking somewhere after creating the wp-config.php and before building the database, as there's no tables created.

    It just doesn't make sense... php memory limit is confirmed at 256M, yet the error currently is failing at about 12 meg (unless my maths is wrong?):

    Fatal error: Out of memory (allocated 11796480) (tried to allocate 7680 bytes)

    Any ideas? I'm getting a bit desperate! :)

  2. kythin
    Posted 5 years ago #

    Also tried compiling Apache with and without suhosin, and when it was with it I tried setting the suhosin.memory_limit too.

    Each time I changed the php.ini I also restarted apache as well before testing.

    Running out of ideas... :S

  3. rfair404
    Posted 5 years ago #

    Kythin, there are other memory limits that could be set on your server aside from the one you mentioned in php.ini. Depending on how your server is set up, you might need to set the memory limit for each site individually. Can you paste the link to your phpini file? that might help.

    Have you spoken to Rackspace?

  4. TCBarrett
    Posted 5 years ago #

  5. kythin
    Posted 5 years ago #

    Thanks tcbarrett, but I've also already tried setting the WP_MEMORY_LIMIT to everything up to 256M with no change :(

    Here's a dump of the phpinfo. For security reasons I've removed the references to the actual server I'm talking about here:


  6. kythin
    Posted 5 years ago #


    Okay so the moral of the story is that when configuring WHM after installing it, if you're running it on a VPS then do NOT run the "Memory Usage Restrictions" in Apache Config.

    What that does is incorrectly limits the memory access of apache threads, mine had set it to 99meg (in total, for all of apache, not just php).

    To fix it, I manually edited httpd.conf and removed the two lines right at the top that the script adds. RLimitMem and RLimitCPU. Then, restarted Apache and bam. Success!

  7. jamesfawcett
    Posted 4 years ago #

    Thanks kythin! FIXED TOO!
    tried everything, searched all over google, your last post sorted this out for me by removing those two lines in /usr/local/apache/conf/httpd.conf

    all up and running, just signed up to say thanks :)

  8. kythin
    Posted 4 years ago #

    Woohoo, that's great! Makes it all worth it! :)

Topic Closed

This topic has been closed to new replies.

About this Topic