Support » Fixing WordPress » Fatal Error: Out of Memory

  • Hi, I’ve read the faq in
    http://wordpress.org/support/topic/279132?replies=84

    but none of the methods worked. Modifying the .htaccess with the line suggested makes the whole thing go down and I just get a misconfiguration type of error.

    Removing all plugins helps in that a user can at least load the blog, whereas with all the plugins this is not possible. However, I can’t edit anything without incurring in an Out Of Memory error.

    I checked the php configuration on my host (I can’t access it directly, as it seems, but I can see what’s been configured) and the memory_limit variable is set to 512M so I can’t understand why something like:

    Fatal error: Out of memory (allocated 11272192) (tried to allocate 77824 bytes) in /home/manchees/public_html/earlyejaculationcure.com/blog/wp-admin/menu-header.php on line 91

    appears…Other pages like /post.php or the like just show a BLANK screen…

    I would really appreciate your help!

    M

Viewing 6 replies - 1 through 6 (of 6 total)
  • Contact your host on this issue. Forward this error to them.

    Thank you bittup. I actually already did it..Just forgot to mention.
    So you think the issue to be on the host side? I was pondering whether to delete wp-* directories and upload them new..I wanted to couple this operation with an upgrade of the software, are there any caveats?

    M

    Hehe, your scripts are running out of memory, ahem, prematurely, causing your site to errr, go down all too soon, in a rather disappointing manner.
    As WordPress, umm, grows and gets more features, the memory requirements are probably only going to… Northwards.

    If you’ve not got access to your php.ini and you’ve tried the .htaccess and wp-config.php fixes, yes, speaking to your host to see if they’ll increase the amount of memory allocated to your php scripts is probably your best bet.

    Awright alism,

    however I saw in the settings I should have 512M for my php scripts..Now do I read the error correctly? It seems that

    1) 11M are already in use
    2) the request for 77M extra failed

    but 1)+2) doesn’t give a number greater than 512M..This puzzles me.

    Next thing for which I’ll need help: how do I track which component is sucking 77M (or even more) of memory?

    M

    mwooton

    i am as frustrated as you, I am having the same problems.

    FYI the script is adding 77K not 77M. doesn’t make sense.

    my site is set to 64M, I am getting fatal errors at 20M.

    Hi,

    Check with these options:

    1) Please check php.ini file in the root/public_html folder of your site. Open php.ini file in text editor and change the values for memory_limit. By default it should see memory_limit = 8M. Try changing it to 12M. if it wil not resolve the problem then try to increase it either 16M or 24M.

    2) If you can’t find the php.ini file, open up the PHP file which requires more memory and add this line just after ini_set(’memory_limit’, ‘12M’); we can increase memory upto 16M or 24M to resolve the issue. But do it try with 12M first.

    3) In last, open the .htaccess file from the root/public_html folder and add this line php_value memory_limit 12M

    From anyone of these trick you can work and rid out from the PHP error. You can increase memory limit according to your requirement.

    Thanks,

    Shane G.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal Error: Out of Memory’ is closed to new replies.