Fatal Error: Out of Memory (4 posts)

  1. A2JC4life
    Posted 4 years ago #

    I have been here off and on for years trying to sort out this blasted "out of memory" error. I get this error when trying to upload a picture with one dimension larger than 400px to a post, when automatically installing most plugins, and when attempting an automatic upgrade.

    BUT I am also getting these errors 100% of the time in my dashboard. And, from time to time, I am getting one at the top of a page in my admin panel, that prevents me completely from doing what I need to do.

    The problem does not seem to be tied to a particular plugin, etc.

    I have already tried increasing my memory to 128 by all of the methods suggested on this forum. I have talked to my host, and he agrees that there is no way a WP installation should truly be using more memory than that, so we think the problem is something else.

    I have this issue on multiple WP installations, but not on ALL of them. I have tried finding a new host, and moving one of my blogs over there, and have the same issue, so I don't think it's the host.

    I have noticed that if I do a clean install, it's fine, but as soon as I move my database in, I get the errors, so I'm wondering if it's a database error of some kind.

    This thread seems most closely to follow my issue, and "Nigel" seems to have encountered the same thing I did. But I don't have a database backup I can install from a time before the errors. (That is, the errors started soooo long ago that I can't go back that far without losing hundreds of posts.) Is there some way to diagnose and fix this type of error, without just wiping out the database and starting over?

  2. ustyne
    Posted 3 years ago #

    I am currently experiencing the same exact issue. The most amazing thing is that it points to different files and of different line number

    Fatal error: Out of memory (allocated 31719424) (tried to allocate 2037 bytes) in /homepages/12/d278792027/htdocs/xxxxxxxxxx/xxxxxxxxx/wp-includes/class-simplepie.php on line 13263`
    I have done everything from increasing size limit to 128M on both wp-config.php, .htaccess, wp-settings.php and on my php.ini file all on the wordpress root folder.

    I can see you have been through thick and thin with this and am really narrowing it down to the number of plugins on wordpress. I have about 24 plugins running and all are very important to what I want my site do. I am still searching.

  3. hanscode
    Posted 3 years ago #

    Hi A2JC4life

    did you fix this issue? or not yet

  4. ustyne
    Posted 3 years ago #

    I call by hosting company and they told me I only have 16MB on the server that my files are being hosted so I asked them to upgrade it and that fixed the issue,

Topic Closed

This topic has been closed to new replies.

About this Topic