[resolved] Fatal Error: Out Of Memory (14 posts)

  1. chanel
    Posted 5 years ago #


    When I try to access the Dashboard, I get this error:

    Fatal error: Out of memory (allocated 24117248) (tried to allocate 75921 bytes) in /home/santanam/public_html/wp-admin/includes/admin.php on line 22

    Tried googling and found no answer. I have access to the files via ftp. Any help would be greatly appreciated.

  2. kreativjustin
    Posted 5 years ago #


    Before posting you should search for relevant issues.

    Within this forum there is a post created for the very same issue you are having. You can try checking this out and see if you have any results.


  3. chanel
    Posted 5 years ago #

    It's not quite the same issue, because I am getting the issue when I am trying to access the admin section. Plus, when I change the memory to admin_memory_limit', '256M', I then get the same error message, but it will state for template.php.

    Thanks anyway.

  4. chanel
    Posted 5 years ago #

    I am now getting this error:

    Fatal error: Out of memory (allocated 26214400) (tried to allocate 122880 bytes) in /home/santanam/public_html/wp-admin/includes/template.php on line 634

  5. chanel
    Posted 5 years ago #

    I've deleted most of the plugins and was able to get the login page to load, but once I log in, I get this:

    Fatal error: Out of memory (allocated 25952256) (tried to allocate 122880 bytes) in /home/santanam/public_html/wp-admin/includes/dashboard.php on line 88

  6. chanel
    Posted 5 years ago #

    Update: I've tried locating the php.ini, but there is none. I've tried the steps where you add your own and edit the wp-config.php file but that still doesn't help.

  7. sofaking21
    Posted 5 years ago #

    This is definitely a problem with your php configuration. Create a phpinfo.php in your document root and look at the results of your config. You stated you have FTP access, is this your server or is it hosted by a third party? If it's hosted by a third party, it's likely that you simply don't have access to the php configuration directory and you will need to contact your host to fix your issue.

  8. chanel
    Posted 5 years ago #

    Thank you for the response sofaking.

    So do I create the phpinfo.php like this: http://santanamaria.com/phpinfo.php and just leave it blank?

    I am actually working on this site for a client and no, this is not her own server. She pays a monthly fee for hosting (she's using the same hosting company and plan that I have).

  9. sofaking21
    Posted 5 years ago #

    So, what you'll do is upload a phpinfo.php file to /home/santanam/public_html/. The content of this file should be:
    <?php phpinfo(); ?>
    Once the file is in place, you should be able to navigate to http://santanamaria.com/phpinfo.php and see how the server is configured. Print out the results and then remove the phpinfo.php file. There is a ton of information contained within this configuration printout that can help diagnose the problem. I'm leaning towards the fact that their PHP processes are tanking on one or more load-balanced servers. The reason why I say that is becasue I had the exact same issues on my servers a few months back. I would shoot the hosts helpdesk an email or a phone call.

  10. chanel
    Posted 5 years ago #

    I don't know how to read/write php. I'm mostly a copy and paste person, once you give me instructions. I've created the file and here's the result.


    What should I do next?

  11. chanel
    Posted 5 years ago #

    I had to contact the hosting company about it. They fixed it within 30 minutes. They didn't state how, or why that happened, but they did say that it was an issue that only they can fix.

    Thank you to everyone else that submitted their advice.

  12. jonhjonh3000
    Posted 5 years ago #

    Hello all,
    trying to update from WordPress 3.1.1 to 3.2.1, with site network activated (2 sites) I get the same kind of error :
    Fatal error: Out of memory (allocated 30932992) (tried to allocate 4580905 bytes) in /homepages/##/######/htdocs/wp-includes/class-http.php on line 1426

    Tried all the fixes like:
    - deactivated all plugins
    - added the line to wp-config.php to up the memory limit.
    - even cleaned the database by removing all revisions of pages and posts (thanks to "Revision diet" plugin)

    Did not do the trick, I cannot get wordpress to update and I get the exact same error every time. any clue?

    by the way, is it really a php memory error? I have noticed that WordPress gives me "Php fatal error" in other cases (that are now solved), in this case it's only "fatal error".

  13. breezotoo
    Posted 5 years ago #

    I get exactly the same error - down to the line number on mine!

    Somebody must have resolved it or it's a host issue?


  14. Ted-writer
    Posted 4 years ago #

    I report the same problem as the previous two.

Topic Closed

This topic has been closed to new replies.

About this Topic