Support » Plugin: ZenCache » Fatal Error or Blank Page with v150626

  • ResolvedPlugin Author Raam Dev

    (@raamdev)


    If you installed ZenCache v150626 and received a PHP Fatal Error and/or discovered “blank pages” (which is what happens when a PHP Fatal Error occurs and you have show errors disabled), please note that we have identified an issue with the latest version of ZenCache (v150626; both Pro and Lite) on web hosts that are running PHP v5.3.2 with APC Cache enabled. What’s occurring is actually a PHP Bug (see PHP Bug #52144) with PHP v5.3.2 + APC Cache.

    We are currently tracking this issue as it relates to ZenCache here: https://github.com/websharks/zencache/issues/511

    All further updates regarding this issue will be made at the above link. If you want to follow along, please leave a comment on that GitHub issue so that you receive updates, and thank you for your patience while we fix this important issue.

    https://wordpress.org/plugins/zencache/

Viewing 10 replies - 1 through 10 (of 10 total)
  • php5.6 w/ built-in opcache enabled also results in 503. I had to remove Zencache manually.

    Same here php 5.5.18

    Plugin Author Raam Dev

    (@raamdev)

    @hlanggo @djkavaa Can you tell me if you’re running APC Cache (and if so, which version; you can find out via phpinfo() or the WordPress phpinfo() plugin).

    @djkavaa Do you have OPcache enabled?

    PHP Version 5.6.10

    I looked in my phpinfo, there is no APC. Seems to just be using Zend OPcache.

    Plugin Author Raam Dev

    (@raamdev)

    @hlanggo Perfect. Thanks for providing those details.

    We’re still working on this and I’ll leave an update here when I have a resolution.

    Bit confused.

    If this is a known bug, why was I allowed to update? Update totally wiped out the site. Getting fatal error and renaming plugin folder results in a blank page.

    Seems to me that if this serious, show stopping bug was known, why allow people to update?

    Bad business in my eyes.

    I would just like to get my site (actually worse, client’s site) back working.

    Cannot log into admin, nothing. Site dead:

    Warning: require_once(/home/xxxxxx/public_html/wp-content/plugins/zencache/plugin.php): failed to open stream: No such file or directory in /home/xxxxxx/public_html/wp-content/plugins/zencache/zencache.php on line 17

    Fatal error: require_once(): Failed opening required ‘/home/xxxxx/public_html/wp-content/plugins/zencache/plugin.php’ (include_path=’.:/usr/local/php54/pear’) in /home/xxxxxx/public_html/wp-content/plugins/zencache/zencache.php on line 17

    How do I remove zencache and get the site back working?

    You have to remove Zencache manually.

    Follow the instructions at the bottom of the following page:
    https://wordpress.org/plugins/zencache/faq/

    Nothing worked for me on the troubleshooting tips page. Ran out of time and just had to pay for help.

    Should have never updated when I was out on the road away from my desktop. Removed the plugin and found another.

    Best of luck.

    Plugin Author Raam Dev

    (@raamdev)

    @hlanggo @djkavaa @texasbiz This issue has been resolved in today’s update (v150709). Please see the changelog.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fatal Error or Blank Page with v150626’ is closed to new replies.