Support » Plugin: Caldera Forms - More Than Contact Forms » Fatal error on version 1.8.9 and 1.8.10

  • Hello,
    Thanks for this handy plugin!
    I get on my sites where the plugin is installed the following error :
    [28-Feb-2020 11:57:34 UTC] PHP Fatal error: Cannot use calderawp\calderaforms\pro\api\local\settings as settings because the name is already in use in /home/***/www/wp-content/plugins/caldera-forms/includes/cf-pro-client/classes/hooks.php on line 10
    No access anymore to site admin because of this fatal error…
    I commented the line 10 of hooks.php :
    use calderawp\calderaforms\pro\api\local\settings;

    I guess this is not the best solution to fix this.
    Some advises ?

    Thanks in advance. Joël

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same error with caldera 1.8.10

    • This reply was modified 5 months, 1 week ago by domitilleggg.
    jojaba

    (@jojaba)

    Hello!

    I know that developping extension is not easy to manage. But if you have fatal errors on it (it seems, I’m not the only one that encounter this issue), you should work on it… 😉
    Could you please just reply to confirm you saw this issue and are working on it!
    Added ticket on github: https://github.com/CalderaWP/Caldera-Forms/issues/3513#issue-579293947

    Thanks in advance. Joël.

    Edit: just saw that 1.8.11 has same issue!

    • This reply was modified 5 months ago by jojaba. Reason: added git ticket link
    • This reply was modified 5 months ago by jojaba.
    lukesnider

    (@lukesnider)

    I am having the same issue updating to version 1.8.11 from version 1.8.8.

    Fatal error: Cannot use calderawp\calderaforms\pro\api\local\settings as settings because the name is already in use in /wp-content/plugins/caldera-forms/includes/cf-pro-client/classes/hooks.php on line 10

    Please advise!

    Can somebody confirm that this happens only with free version of plugin?

    It only seems to happen on PHP 5. I’m experiencing same problem using Caldera Forms v1.8.11 (from wordpress.org) on PHP 5.6. If I switch the site to PHP 7.0 (or higher) the problem is gone.

    Conclusion: Caldera Forms is no longer compatible with PHP 5.x. PHP 5.6 has been EOL for more than a year now, but there’s still very many sites running it.
    https://www.php.net/eol.php

    • This reply was modified 4 months, 3 weeks ago by y0uri. Reason: added link to PHP.net
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.