Support » Plugin: Image Optimizer, Resizer and CDN - Sirv » Fatal error on upgrade to v4.0

  • Resolved colinfroggatt

    (@colinfroggatt)


    Hi. I have an issue with a site using Sirv. The upgrade from v3.7.5 to v4.0 has generated a fatal error. WP id’s the error as in the Sirv plugin after update.

    I have reverted back to a backup with v3.7.5, and tried to update again and get the same result – the fatal error and a dead site.

    Error is below:

    
    An error of type E_ERROR was caused in line 165 of the file /zzzzzz.co.uk/httpd.www/wp-content/plugins/sirv/sirv.php. Error message: Uncaught Error: Call to undefined function dbDelta() in /zzzzzz.co.uk/httpd.www/wp-content/plugins/sirv/sirv.php:165 Stack trace: #0 /zzzzzz.co.uk/httpd.www/wp-content/plugins/sirv/sirv.php(109): fix_db() #1 /zzzzzz.co.uk/httpd.www/wp-includes/class-wp-hook.php(288): sirv_upgrade_plugin('') #2 /zzzzzz.co.uk/httpd.www/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #3 /zzzzzz.co.uk/httpd.www/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #4 /zzzzzz.co.uk/httpd.www/wp-settings.php(392): do_action('plugins_loaded') #5 /zzzzzz.co.uk/httpd.www/wp-config.php(103): require_once('/zzzz../...') #6 /zzzzzz.co.uk/httpd.www/wp-load.php(37): require_once('/zzzz../...') #7 /zzzzzz.co.uk/httpd.www/wp-login.php(12): require('/zzzz../...') #8 {main} thrown
    

    WordPress version 5.3
    Current theme: Neve (version 2.5.2 )
    Current plugin: Sirv (version 4.0)
    PHP version 7.3.12

    Any help appreciated. -Colin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi Colin,

    Thanks for reporting this and apologies for the issue. That error has not been seen before and we must investigate why that happened. Can you please send us a login to your WP admin via our secure contact form here please?

    https://sirv.com/contact/

    Thanks,

    David
    Sirv Support Team

    We have been investigating this and may have found the cause of the issue. A new plugin version will be released shortly.

    Meanwhile, you can disable the plugin like so:

    1. Login to your server via FTP.

    2. Navigate to the Sirv plugin folder here:

    /wp-content/plugins

    3. Remove the Sirv plugin folder. For example, you can move it to one folder higher:

    /wp-content

    A new plugin version 4.0.1 has been released, which should resolve the problem.

    Please update to the new version. If you need help, please contact us via our secure form at:

    https://sirv.com/contact/

    We will help you ASAP.

    Thread Starter colinfroggatt

    (@colinfroggatt)

    Hi. That fixed it – thank you for the super fast turn-around!

    After upgrading to v4.x I also had to reconnect to my Sirv account using Sirv login details and re-enable lazy load etc. Seems old settings were lost.

    There was a line in the release notes about using account login rather than amazon credentials, but it could probably have been a bit more explicit about needing to reconnect.

    Regardless, all is well and thanks again for the responsive support 🙂 -C

    Hi Colin,

    Another update has been released (v4.0.2) which includes a message on all pages to reconnect your Sirv account. Lazy load and other settings are restored too.

    Thanks for raising this!

    David
    Sirv Support Team

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error on upgrade to v4.0’ is closed to new replies.