Support » Fixing WordPress » Fatal Error on Upgrade

  • Resolved CLASS1

    (@class1)



    Hello:
    On auto update of my site from 4.5.4 to V 4.6.1, I got this return error:
    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 79 bytes) in /data/20/3/159/5/3159983/user/3527141/htdocs/wordpress1/wp-includes/wp-db.php on line 1837

    Now, I cannot even log in to to WP Log In page for my site. It just shows the above error.
    However, the site is still there, which is:
    http://classlifestyle.com

    Does anyone know what I can do? Do I need to totally uninstall WP and re-install?

    Thank you.

    • This topic was modified 2 years, 3 months ago by  CLASS1.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Team Volunteer

    Thanks Steve, however even trying to log in to WP on a new computer with 8 GB of memory, I still cannot log in and just get the same error. Although I was on the old XP low memory computer when I was trying to do the upgrade.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Team Volunteer

    It has nothing to do with the memory on your computer; this is a server-side setting for WordPress.

    As @sterndata said, its not your PC’s memory its the server’s memory, contact your web-host about this 😀

    Thank you Steve. I looked at your links. Will call my host to see if they can increase the php.ini file memory.

    Hi Steve:
    My host sent me instructions on how to add the memory to my ftp files. It works great now.
    Here is how I did it for others on the forum:

    Step 1:Connect via FTP to your hosting package’s primary FTP account.

    Step 2: Navigate to the /cgi-bin folder and determine if you have a file there called php.ini. If you do, please download it to your computer for editing.

    Step 3: Once the file is downloaded open it with Notepad on a PC or TextEdit on a Mac. If the file did not exist create a new file and save it with the file name php.ini (must be lowercase).

    Step 4: Add the below lines of code to the file and save it.

    memory_limit = 64M
    output_buffering = 2048

    Step 5: Upload the saved file to the FTP server and place it in the /cgi-bin fodler.

    Step 6: Navigate to the /cgi-bin/.php folder and locate the php.ini.coalesced file and delete it.

    Step 7: Browse to any PHP enable page on your site and the new settings will be enabled.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Team Volunteer

    Keep in mind that method may be specific to your host.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal Error on Upgrade’ is closed to new replies.