Support » Plugin: Redis Object Cache » Fatal error on settings page after updating to 2.0.2.

  • Resolved Rob Migchels

    (@dhrrob)


    Hey there,

    After updating from v1.6.2 to v2.0.2 I’m getting a critical error when accessing https://example.com/wp-admin/options-general.php?page=redis-cache, see below. I’ve also added a Site health report.

    [14-Jul-2020 07:59:38 UTC] RedisException: Connection refused in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php:566
    Stack trace:
    #0 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(566): Redis->connect('127.0.0.1', '7009', 1, '', NULL, 1)
    #1 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(411): WP_Object_Cache->connectUsingPhpRedis(Array)
    #2 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(162): WP_Object_Cache->__construct(true)
    #3 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/load.php(580): wp_cache_init()
    #4 /home/a100546/domains/example.com/public_html/helpdesk/wp-settings.php(133): wp_start_object_cache()
    #5 /home/a100546/domains/example.com/public_html/helpdesk/wp-config.php(80): require_once('/home/a100546/d...')
    #6 /home/a100546/domains/example.com/public_html/helpdesk/wp-load.php(37): require_once('/home/a100546/d...')
    #7 /home/a100546/domains/example.com/public_html/helpdesk/wp-admin/admin.php(34): require_once('/home/a100546/d...')
    #8 /home/a100546/domains/example.com/public_html/helpdesk/wp-admin/options-general.php(10): require_once('/home/a100546/d...')
    #9 {main}
    [14-Jul-2020 07:59:38 UTC] RedisException: Connection refused in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php:566
    Stack trace:
    #0 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(566): Redis->connect('127.0.0.1', '7009', 1, '', NULL, 1)
    #1 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(411): WP_Object_Cache->connectUsingPhpRedis(Array)
    #2 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(162): WP_Object_Cache->__construct(true)
    #3 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/load.php(580): wp_cache_init()
    #4 /home/a100546/domains/example.com/public_html/helpdesk/wp-settings.php(133): wp_start_object_cache()
    #5 /home/a100546/domains/example.com/public_html/helpdesk/wp-config.php(80): require_once('/home/a100546/d...')
    #6 /home/a100546/domains/example.com/public_html/helpdesk/wp-load.php(37): require_once('/home/a100546/d...')
    #7 /home/a100546/domains/example.com/public_html/helpdesk/wp-cron.php(44): require_once('/home/a100546/d...')
    #8 {main}
    [14-Jul-2020 07:59:40 UTC] PHP Fatal error:  Uncaught RedisException: Redis server went away in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/plugins/redis-cache/includes/class-plugin.php:236
    Stack trace:
    #0 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/plugins/redis-cache/includes/class-plugin.php(236): Redis->zRangeByScore('hd:redis-cache:...', 1594711780, 1594713520, Array)
    #1 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/class-wp-hook.php(287): Rhubarb\RedisCache\Plugin->enqueue_redis_metrics('settings_page_r...')
    #2 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #4 /home/a100546/domains/example.com/public_html/helpdesk/wp-admin/admin-header.php(104): do_action('admin_enqueue_s...', 'settings_page_r...')
    #5 /home/a100546/domains/example.com/public_html/helpdesk/wp-admin/admin.php(234): require_once('/home/a in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/plugins/redis-cache/includes/class-plugin.php on line 236
    [14-Jul-2020 07:59:40 UTC] RedisException: Connection refused in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php:566
    Stack trace:
    #0 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(566): Redis->connect('127.0.0.1', '7009', 1, '', NULL, 1)
    #1 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(411): WP_Object_Cache->connectUsingPhpRedis(Array)
    #2 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(162): WP_Object_Cache->__construct(true)
    #3 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/load.php(580): wp_cache_init()
    #4 /home/a100546/domains/example.com/public_html/helpdesk/wp-settings.php(133): wp_start_object_cache()
    #5 /home/a100546/domains/example.com/public_html/helpdesk/wp-config.php(80): require_once('/home/a100546/d...')
    #6 /home/a100546/domains/example.com/public_html/helpdesk/wp-load.php(37): require_once('/home/a100546/d...')
    #7 /home/a100546/domains/example.com/public_html/helpdesk/wp-blog-header.php(13): require_once('/home/a100546/d...')
    #8 /home/a100546/domains/example.com/public_html/helpdesk/index.php(17): require('/home/a100546/d...')
    #9 {main}
    [14-Jul-2020 07:59:40 UTC] RedisException: Connection refused in /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php:566
    Stack trace:
    #0 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(566): Redis->connect('127.0.0.1', '7009', 1, '', NULL, 1)
    #1 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(411): WP_Object_Cache->connectUsingPhpRedis(Array)
    #2 /home/a100546/domains/example.com/public_html/helpdesk/wp-content/object-cache.php(162): WP_Object_Cache->__construct(true)
    #3 /home/a100546/domains/example.com/public_html/helpdesk/wp-includes/load.php(580): wp_cache_init()
    #4 /home/a100546/domains/example.com/public_html/helpdesk/wp-settings.php(133): wp_start_object_cache()
    #5 /home/a100546/domains/example.com/public_html/helpdesk/wp-config.php(80): require_once('/home/a100546/d...')
    #6 /home/a100546/domains/example.com/public_html/helpdesk/wp-load.php(37): require_once('/home/a100546/d...')
    #7 /home/a100546/domains/example.com/public_html/helpdesk/wp-cron.php(44): require_once('/home/a100546/d...')
    #8 {main}
    
    ### wp-core ###
    
    version: 5.4.2
    site_language: nl_NL
    user_language: en_US
    timezone: +00:00
    permalink: /%category%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/a100546/domains/example.com/public_html/helpdesk
    wordpress_size: loading...
    uploads_path: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/uploads
    uploads_size: loading...
    themes_path: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/themes
    themes_size: loading...
    plugins_path: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-dropins (1) ###
    
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: example. Helpdesk (example-helpdesk)
    version: 0.1.1
    author: example.
    author_website: https://example.com
    parent_theme: GeneratePress (generatepress)
    theme_features: automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/themes/example-helpdesk
    
    ### wp-parent-theme ###
    
    name: GeneratePress (generatepress)
    version: 2.4.2
    author: Tom Usborne
    author_website: https://tomusborne.com
    theme_path: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/themes/generatepress
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.4, author: the WordPress team
    
    ### wp-mu-plugins (1) ###
    
    ManageWP - Worker Loader: author: GoDaddy, version: (undefined)
    
    ### wp-plugins-active (12) ###
    
    example Worker: version: 1.2.0, author: Studio example
    Easy Table of Contents: version: 2.0.11, author: Steven A. Zahm
    External Links: version: 6.8.1, author: Denis de Bernardy & Mike Koepke
    GP Premium: version: 1.10.0, author: Tom Usborne
    Imsanity: version: 2.6.0, author: Exactly WWW
    Koko Analytics: version: 1.0.15, author: ibericode
    Lightbox with PhotoSwipe: version: 3.0.5, author: Arno Welzel
    ManageWP - Worker: version: 4.9.7, author: GoDaddy
    Members: version: 3.0.10, author: MemberPress
    Redis Object Cache: version: 2.0.2, author: Till Krüss
    Relevanssi: version: 4.7.2.1, author: Mikko Saari
    Was This Article Helpful?: version: 1.0.2, author: WaspThemes
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1802
    imagemagick_version: ImageMagick 7.0.10-10 Q16 x86_64 2020-05-12 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 57 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 491512
    	imagick::RESOURCETYPE_MAP: 57 GB
    	imagick::RESOURCETYPE_MEMORY: 29 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.32.el7.x86_64 x86_64
    httpd_software: Apache/2
    php_version: 7.4.7 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 90
    memory_limit: 2048M
    max_input_time: -1
    upload_max_size: 16M
    php_post_max_size: 64M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.45-MariaDB
    client_version: mysqlnd 7.4.7
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/a100546/domains/example.com/public_html/helpdesk/wp-content
    WP_PLUGIN_DIR: /home/a100546/domains/example.com/public_html/helpdesk/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 2048M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Rob,

    thanks for posting this error.
    Please try to follow the instructions given here disabling the metrics collection: https://wordpress.org/support/topic/fatal-error-with-2-0-2-2/

    As I said in the linked thread: The error will be resolved in 2.0.3 – in the mean time please add the constant mentioned.

    kind regards
    Naxvog

    Plugin Author Till Krüss

    (@tillkruess)

    Hi @dhrrob,

    Your logs indicate two errors.

    1) PHP Fatal error: Uncaught RedisException: Redis server went away

    This will be fixed in v2.0.3 later today. In the meantime, you can add this to your config to avoid the error:

    
    define( 'WP_REDIS_DISABLE_METRICS', true );
    

    2) RedisException: Connection refused

    This indicates that either your configuration is not correct, or (more likely) that your Redis server is down or not accepting new connections.

    Would you mind posting your “Diagnostics” from “Settings -> Redis”?

    Plugin Author Till Krüss

    (@tillkruess)

    I’ll close this for now. Please let me know if the issue persists.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.