Support » Plugin: Swim Team » Fatal Error on plugin activation

  • Hello,

    I am wondering if anyone has experienced a Fatal Error when trying to activate SwimTeam and what you did to resolve it. I installed and activated the phphtmllib library but get the following error when activating SwimTeam:

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare html_link() in /serverpath/wp-content/plugins/phphtmllib/tag_utils/ on line 948

    (serverpath = the actual sever path)

    Any insight on this would be greatly appreciated.


Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author Mike Walsh


    This sounds like a plugin conflict.

    If you deactivate all plugins except pHpHtmlLib and wp-SwimTeam does it still happen?

    Thanks for the help,

    I did what you suggested, deactivated all plugins, except pHpHtmlLib. But now I got the following errors when attempting to activate SwimTeam:

    Warning: require_once(/home/folder/ failed to open stream: No such file or directory in /home/folder/
    content/plugins/phphtmllib/widgets/data_list/ on line 16

    Fatal error: require_once(): Failed opening required ‘/home/folder/’ (include_path=’/home/folder/’) in /home/folder/ on line 16

    (/home/folder/ = server path)

    Based on the error, seems like it can’t find the wp-config.php file, not sure. If that’s the case, I actually have that file somewhere else for security reasons. I am also noticing the extra slash on the path, seems kind of out of place, so I am not sure if that has to do with the issue also ( I am referring to the two slashes after the in the path before wp-config.php)

    Thank you once again for your input, most appreciative.

    Plugin Author Mike Walsh


    I will take a look at this later this morning. I don’t think phpHtmlLib cares where wp-config.php lives but I could be wrong, it has been a while since I looked at it.

    Plugin Author Mike Walsh


    I just took a quick look at the source code and it definitely is looking for wp-config.php in the default location. I think this is an artifact of when I first put wp-SwimTeam together back in the WordPress 2.7 timeframe.

    All I have with me right now is my iPad so I can’t test it but I think you can comment out line 16 for sure and possibly line 17. If you want to try it and post your results that would be helpful. This is likely the root cause of your original problem.

    I won’t be in front of my computer for several hours to test it myself.

    Plugin Author Mike Walsh


    I just ran a quick test and commenting out line 16 of phphtmllib/widgets/data_list/ seems to be ok. I would appreciate it if you could do a quick test as well and confirm your configuration works as well.

    cannot load plug-ins. I installed both plug-ins, activated the php plug-in and all was well. activated the swim team plug-in and the site freezes. no messages, nothing. Have to shut down and restart the servers and the site will load back up but the swim team plug-in is not activated.

    Plugin Author Mike Walsh


    Need some more details:

    1. Platform?
    2. WordPress version number?
    3. PHP version number?
    4. Other plugins installed?
    5. Theme?

    Have you tried deactivating all other plugins and see if the problem persists?

    I’ve been working on some improvements to wp-SwimTeam and have a beta release available for testing with however I haven’t made any changes to the activation process in quite some time.

    I am on a Mac running Mavericks. I am locally testing this running MAMP. WordPress version is 3.8.1 and PHP is 5.3.6. I do have other plugins installed and have not tried to deactivate them yet. The theme is Anew version 2.0.9 by Alexander Agnarson.

    Plugin Author Mike Walsh


    Since you are running locally, do you have access to the web servers error log? It would be interesting to see if there are any clues in it as to what failed.

    I would start by disabling all other plugins besides phpHtmlLib and wp-SwimTeam and see if the problem persists. If it does, then I would try one of the default WordPress themes (I am partial to TwentyTen myself).

    I am running on IIS with PHP 5.3.13 WP 3.8.1 for development and Linux Apache, PHP 5.2.17 and WP 3.8.1 for production and Ubuntu, PHP 5.5.x, and WP 3.8.1 for testing and have not encountered this problem on any of them nor had any other reports of this.

    I have an old Mac Mini but don’t have it set up for doing any sort of testing so can’t replicate your environment.

    Hello, I have an error in the activation of the plugin:

    The extension could not be activated because it triggered a fatal error.

    Warning: require_once (menus.include.php): failed to open stream: No such file or directory in /home/www/domaine/www/wordpress/wp-content/plugins/wp-swimteam/swimteam.php on line 89

    I’m with WORDPRESS V.4 (Benny)

    OS: Linux
    Server: Apache/2.4.10 (Unix) PHP/5.5.16
    Document Root: /home/www/domaine/www/wordpress

    GD: bundled (2.1.0 compatible)
    Magic Quotes GPC: Off
    Memory Limit: 128,0 MiB
    Max Upload Size: 16,0 MiB

    Maximum No. Connections: 500
    Maximum Packet Size: 64,0 MiB
    Data Disk Usage: 13,0 MiB
    Index Disk Usage: 4,0 MiB

    Do you have any idea why
    Thank you for your help

    Plugin Author Mike Walsh


    This sounds like a missing file or a file permissions problem. The menus.include.php should be in the wp-swimteam/includes folder – do you see the file there?

    not the file is not present

    Sorry, the file exists, I changed the access rights of all the directory to 777 but the error is still the same.

    Plugin Author Mike Walsh


    How did you install the plugin? From the WordPress repository?

    The first thing I would try is to delete the plugin and re-install it from the WordPress plugin repository. I just tested it on my development environment and I am not seeing that error. You are running a newer version of PHP than I am in my development area but I wouldn’t expect that to be a problem.

    I just ran through the deactivation/reactivation on my demo site without any issues. The only thing I can’t easily try is an install from an installation where Swim Team has never been installed before.

    How did you install the plugin? From the WordPress repository? Yes
    phpHtmlLib =>
    SwimTeam => 1.41.1037

    All plugins are disabled except phpHtmlLib.
    I removed and installed again but it does not change.
    Looking at the code in the SWIMTEAM.PHP file and adding the path / include function calls, the error changes.
    Now I have:
    Warning: require_once (textmap.class.php): failed to open stream: No such file or directory in /home/www/domaine/www/wordpress/wp-content/plugins/wp-swimteam/include/shortcodes.include.php on line 20

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Fatal Error on plugin activation’ is closed to new replies.