Fatal Error on my wordpress site, can't get into front or backend, help! (3 posts)

  1. rastinha
    Posted 2 years ago #

    Hi there,

    I'm at a bit of a loose end as I have been working on a classroom site for the new school year over the past week, and today I took a day off (site was working fine yesterday) and I just went to look at it now:


    and I get this error, on the front page and the wp-admin page:

    Fatal error: Call to a member function register_handler() on a non-object in /home/taylormm/public_html/cbox/wp-includes/media.php on line 944

    I have WP 3.5 installed on there, with buddypress 1.6.2, using cbox theme, and plugins (most of which come with commons in a box):


    I have NO idea what has happened since I last looked at it. I searched the forums and found this thread: http://wordpress.org/support/topic/wordpress-35-error-on-line-944 and tried commenting out the lines in media.php, tried adding the remove action function to cbox's functions.php file, and nothing has worked. I have spent ages getting plugins to work with each other on that site and customise it and now I have no idea how to fix it and get it to work, so any help will be GREATLY appreciated!

    The only thing I can think of is that when I opened my browser on ubuntu (was previously working in windows) the wordpress install confirmation page was still open in a tab on my crazydomains cpanel tab, and I wonder if it might have reinstalled the last step overtop or something? I don't really know, just the only thing I can think of that had anything to do with that site today.

    Thanks a lot if you can help me, let me know if you need any more information.


  2. Phil
    Posted 2 years ago #

    Maybe try downloading a fresh copy of WP and copy the files up to your FTP (i.e, a manual upgrade)?

  3. rastinha
    Posted 2 years ago #

    I tried doing that and then I could go to my site again, but it was just a fresh blank empty wordpress ready to start again from scratch. I copied over my old wp-config.php file so it would connect to the old database, and then I got a message saying that wordpress had been updated so now the database needed to be updated. I backed up the old database and clicked ok, and then I still had a blank empty wordpress. It had a list of my old plugins, but none were activated, and when I chose to activate cbox, all of the ones associated with it disappeared from the list and were then reinstalled with that.

    I'm basically starting from scratch now, but with a databse and disk full of the old site that I'm sure is probably going to cause me problems later on :\

    Any other ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic