Viewing 5 replies - 1 through 5 (of 5 total)
  • This will be addressed very quickly, sorry for the inconvenience.

    Boa tarde.

    Possivelmente está a usar uma versão antiga do PHP. Será que nos poderia informar da versão PHP?

    Olá,

    Neste momento a versão instalada é a 5.3.28. Mas por outro lado, tendo em conta que este é o único plugin (em algumas dezenas) em que tenho um problema que devolve um fatal error, julgo que não deverá ser por aí…

    Server Information
    Item Detail
    Server Name server11
    cPanel Version 11.52.1 (build 3)
    Theme paper_lantern
    Apache Version 2.4.9
    PHP Version 5.3.28
    MySQL Version 10.0.20-MariaDB
    Architecture x86_64
    Operating System linux
    Path to Sendmail /usr/sbin/sendmail
    Path to Perl /usr/bin/perl
    Perl Version 5.10.1
    Kernel Version 2.6.32-531.29.2.lve1.3.11.1.el6.x86_64

    Já agora, experimentei a vossa versão 1.1., que voltou a dar o mesmo erro:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘[‘ in /home/my_dir/public_html/my_site.com/wpan/wp-content/plugins/woo-billing-with-invoicexpress/vendor/sabre/uri/lib/functions.php on line 37

    Obrigado

    Todo o plugin foi desenvolvido tendo em conta a versão mínima 5.4 do PHP. Iremos por essa indicação na descrição do plugin. Aconselho-o vivamente a fazer o upgrade, pois essa versão já foi descontinuada há 1 ano e 4 meses.
    http://php.net/eol.php

    Obrigado pela sugestão. Mas tendo em conta que tenho perto de uma dezena de sites diferentes a correr em WordPress e outras plataformas, esse procedimento pode não ser a coisa mais razoável a fazer. Talvez seja por isto mesmo que o próprio WordPress só exija mudança de versão de PHP entre largas iterações.
    Vou analisar, mas provavelmente devo mudar de sistema de faturação, que era a ideia até surgir o vosso plugin.

    Obrigado

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error on install’ is closed to new replies.