Support » Plugin: Simple Calendar - Google Calendar Plugin » Fatal Error on Homepage

  • Resolved bezerbezer

    (@bezerbezer)


    Hey guys,

    So I’ve noticed a few times that after you update the plugin my homepage disappears and I get the message: “Fatal error: GCE_Display::get_event_days(): The script tried to execute a method….” See link below for full message. When this message appears on the page, none of the homepage content gets displayed. Only this message.

    I understand these updates are necessary, and I do very much appreciate the hard work you guys put into this, but is there anyway to avoid messing up the whole page? I don’t mind if the plugin is down for a while, but when it disables the whole homepage, its kinda rough.

    Any ideas on how I can avoid this?

    Thanks & happy holidays!
    Adam

    https://wordpress.org/plugins/google-calendar-events/

Viewing 15 replies - 1 through 15 (of 86 total)
  • Plugin Author Nick Young

    (@nickyoung87)

    Adam,

    Sorry for the issue I can see how it would be frustrating. I actually haven’t heard of this happening before. I will see if I can poke around in the update code and elsewhere to see why this might be happening.

    A couple of questions:

    – It only happens after an update?
    – What theme are you using?
    – Any other plugins installed that could be conflicting?
    – What version of WordPress are you running?

    Again, I apologize for the inconvenience, but hopefully we can work together to get this sorted out for you.

    Thanks!

    Hey Nick,

    Thanks for the swift reply!

    Well from what I can tell, I think its only after updates… This time it was exactly what happened. Although last Saturday night I checked in around 3am and got the error message and I’m not sure an update followed that event. I reloaded and it was fine… So I guess it hasn’t happened enough to where I can speak with great accuracy… I’d try to debug it myself, but has only happened 2-3 times.

    I’m using a theme called “Mural” which doesn’t usually feel glitchy, but of course it can always be on account of some conflicting code.

    I am using 5 other plugins: CSS Plus, Mashshare Share Buttons, Responsive Lightbox, SlideDeck 2, and XYZ Contact Form.

    As far as I can tell, I’m running the latest version of WP.

    Here’s the site, if its any help: solar1.org

    You guys rock, thanks Nick!

    Plugin Author Nick Young

    (@nickyoung87)

    @bezerbezer,

    Sorry but I still haven’t been able to replicate this. I am going to mark as resolved for now since you are the only person reporting it and it seems infrequent. If you narrow it down a bit or it starts to happen more often then please please let me know so I can try a go at it again.

    Thanks!

    Ok Thanks for trying Nick! I appreciate it. Especially over the holidays. I’ll let you know if I see it again and if I can get better specifics.

    Best,
    Adam

    Hey Nick,

    It happened again just now — at about 2:30-3pm on Monday 1/5/14.

    Were you guys working on anything or updating?

    I was on the site earlier today, and it was perfectly fine. This time, I immediately started deactivating plugins to trouble shoot, and I started with GCal Events. Once I deactivated and then reactivated, the site was back up. Perhaps I should have started with another plugin (using 6 plugins, all generally pretty popular and safe).

    Regardless, my grid view calendar on the events page does not seem to be populating….

    Other characteristics: I have a Mac here at work, and a Mac at home. The first time I saw the fatal error test, I was at home. However, when at work, where everyone else is on a PC, it seems to be working fine. So I’m not sure what that means since it affected my Mac at home and not the Mac at work. Both are running the same OSX. But apparently PCs always show the fatal error if it is up.

    Very, very sorry to bug you with this again, but I might be leaving this job soon, so I’d love to try to trouble shoot if possible. I’d be happy to give you an Admin account for my site if that were to make it any easier for you?

    Thanks as always.
    Adam
    http://www.solar1.org

    Plugin Author Nick Young

    (@nickyoung87)

    Hey Adam,

    Really sorry that happened to you. I would start by double checking all your settings to make sure they are still correct. Mainly these:

    – API Key
    – Calendar ID
    – Minimum Feed Start Date
    – Maximum Feed End Date

    You can also try clearing the cache for the feed just to make sure.

    For the fatal error you are getting on PCs does it only happened when logged in? I am on a PC and don’t see a fatal error warning so that is why I ask.

    Let me know if checking the settings helps and if not I will try to dig deeper for you so we can get it up and running again.

    Hey Nick,

    Very sorry to keep coming back to you with this one, but the website (solar1.org) keeps going down when you guys make updates (after you make the update, but before I update the plugin on my end). Sometimes it goes down the day after I update, as well. I’ve tried everything you’ve suggested and done as much trouble shooting as I can come up with. My boss is getting annoyed at this, however I greatly prefer your plugin to your competition (you guys are pretty obviously the best). So I’d love it if we could try one more time to fix it, if possible…?

    Here’s the specifics below. Please hit me up if you have any ideas. And thanks a million!!
    Adam

    Here is a screen shot of what the website looks like when it goes down:
    http://solar1.org/wp-content/uploads/2015/04/fatal.error_.jpg

    Here’s the error message:
    Fatal error: GCE_Display::get_event_days(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition “GCE_Event” of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/content/p3pnexwpnas05_data03/96/2347196/html/wp-content/plugins/google-calendar-events/includes/class-gce-display.php on line 61

    And here is the code at line 61 of that document:

    /**
    	 * Returns array of days with events, with sub-arrays of events for that day
    	 *
    	 * @since 2.0.0
    	 */
    	private function get_event_days() {
    		$event_days = array();
    
    		foreach ( $this->merged_feeds as $event ) {
    (Line 61)	foreach ( $event->get_days() as $day ) {
    				$event_days[$day][] = $event;
    			}
    		}
    
    		return $event_days;
    	}

    Plugin Author Nick Young

    (@nickyoung87)

    Hey Adam,

    Sorry that this is happening to you more frequently lately. I will do what I can to figure out what’s going on here. I find this bit particularly interesting:

    (after you make the update, but before I update the plugin on my end).

    So as soon as we push an update to the repo it seems like you start getting the error?

    Hey Nick,

    Yes, that’s my guess anyway, but I really don’t know when you push it through, of course. All I know was this morning I came in to work and it was down. It happened about 2 weeks ago or something, you recently pushed another update though, correct? It only tends to happen when you make an update. So I’ll update the plugin, clear the cache, and walk away. But sometimes the next day it goes down again and I just have to clear the cache in order to bring it back online. After that it tends to be fine until another update comes around. Very strange.

    thanks man! Let me know if you want me to try anything on my end. best,
    a

    Plugin Author Nick Young

    (@nickyoung87)

    Do you have any sort of caching plugin installed by chance?

    Its a GoDaddy thing that is automatic — its not “plugged in” on my end.

    Its part of their wordpress package.

    Plugin Author Nick Young

    (@nickyoung87)

    Hmm..I wonder if that has anything to do with it. Thanks for the info. I will keep you posted if I come up with anything.

    Thank you so much for your patience!

    Hi everyone, we are having the exact same issue that bezerbezer is having a site we have launched. This is hosted at Media Temple. We believe it has something to do with the cache settings on the servers but are unsure. Any additional direction here would be very helpful.

    You can see a screenshot of the error and the homepage at this link — https://dl.dropboxusercontent.com/u/11859496/Home%20%20%20College%20of%20Mount%20Saint%20VincentCollege%20of%20Mount%20Saint%20Vincent.png

    Plugin Author Nick Young

    (@nickyoung87)

    @ericrowley,

    Thanks for letting us know. Still trying to figure this one out. Seems like it could be a server configuration kind of thing, but not 100% sure at this moment. I will keep you both posted if we can get it worked out.

    Thanks for your patience!

Viewing 15 replies - 1 through 15 (of 86 total)
  • The topic ‘Fatal Error on Homepage’ is closed to new replies.