WordPress.org

Support

Support » Plugins and Hacks » Ultimate Tag Cloud Widget » Fatal Error on "construct"

Fatal Error on "construct"

  • Hi guys,

    i installed the last version of plugin on a 3.0.4 wordpress instance. When i active the plugin i have di error:

    Catchable fatal error: Argument 1 passed to UTCW::__construct() must be an instance of UTCW_Plugin, boolean given, called in C:\xampp\htdocs\fuu\wp-includes\widgets.php on line 77 and defined in C:\xampp\htdocs\fuu\wp-content\plugins\ultimate-tag-cloud-widget\utcw-widget.php on line 38

    I tried to install it on a 3.0.4 vergin wp instance too. Can someone help me please?

    Of course no problem with wp 3.5 but a client is stuck on 3.0.4 -.-

    http://wordpress.org/extend/plugins/ultimate-tag-cloud-widget/

Viewing 9 replies - 1 through 9 (of 9 total)
  • I just tested this myself and it seems like there’s a problem with older versions of WordPress.

    I’ll try to get to this issue this weekend.

    Thanks you Rickard!!! I will try to work on it too.

    Little update.

    In utcw_widget.php in line 40 i changed:

    parent::WP_Widget( false, __( 'Ultimate Tag Cloud', 'utcw' ), $options );

    with

    parent::__construct( false, __( 'Ultimate Tag Cloud', 'utcw' ), $options );

    This is the PHP5 constuct, WP_Widget is for PHP4.

    Now i’m able to use the plugin BUT when i click on Terms, Basic Appearence, ect it doesn’t switch. I have a classic POST-call, it return on “Data” and i’m not able to access in the others option page.

    Hi, thank you for also taking a look at this.

    To me, this sounds like a PHP version incompatibility. What version of PHP are you using?

    Hi,

    i’m using php 5.3.8

    But with wordpress 3.5 (on the same php version) the plugin works fine.

    I deleted all <fieldset> tag from setting.php

    Now i’m able to see and use all others option but i have all on the same box ofc.

    Anycase i think the problem is in javascript and not in php. Does the script (utcw.min.js) depend on others script??

    Tnx.

    The utcw.js script depends on jquery only, and should be compatible with the jquery version all the way back to 3.0.

    I’ll try installing old wordpress and see for myself.

    I tried to load jquery 1.8.3 (it’s in wp 3.5) instead the old version, but it doesn’t work.

    🙁

    Sorry, haven’t had the time to look more into this. Will get back as soon as I have had a look.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal Error on "construct"’ is closed to new replies.
Skip to toolbar