Support » Plugin: WordPress Move » Fatal Error on Activation of WordPress Move

  • Resolved geeaygee


    I am trying to move a WP installation from one server to another so I downloaded WordPress Move & installed it in the old installation with no problems. I then did a backup which worked fine. I downloaded the 3 zip files & a sql file to my PC.

    The former installation was in a stand-alone account ie it was the only Domain,

    The new installation has the same Domain name as the old one but it is now an add-on domain. WP 3.3.1 has installed with no problems.

    However I can upload WP Move but when I try to activate it I get the following message

    Plugin could not be activated because it triggered a fatal error.

    Can anyone advise why this has happened & how I can fix it.

    I am not a WP user, I am doing this for a client who does. I have also downloaded all the files from the old installation as unfortunately that account has now been deactivated. I was hoping to have his all resolved before that happened.

    Thanks for any help

Viewing 15 replies - 1 through 15 (of 18 total)
  • if you enable debug mode PHP should spit out what’s triggering the error in the plugin.. likly server config, or php version.. & depending on your PHP skill level / the host options you can solve the problem

    Plugin Author Mert Yazicioglu


    As davidsword said, your server configuration and/or PHP version is causing this problem. There are a few other users experiencing the same issue but since I haven’t been able to reproduce the error yet, I’m unable to provide a fix.

    Could you please tell me which version of PHP you are running?

    Thank you!

    I am really not familiar with PHP at all so not sure how to enable debug mode but will have a look & see if I can work it out.

    I am running PHP Version 5.2.8

    I hope you can help as I am stuck not being able to load the backup files into the new installation.


    I set the debug to true in wp-config.php

    define(‘WP_DEBUG’, true);

    & then tried to activate WordPress Move but got the fatal error message but no extra info. Where would it show?


    I also have the fatal error on activation issue using wp-move version 1.3.

    I’m trying to use the plugin on a development site on localhost.

    I’m using WordPress 3.3.1 and php 5.3.8. I’ve deactivated all other plugins.

    I’ve turned on wp-debug but I get no further information.

    Any ideas?


    Plugin Author Mert Yazicioglu


    Really interesting. I can confirm that it works with PHP 5.2.5 and 5.3.6 so the problem is most probably not related to the PHP version.

    I’m still working on trying to reproduce this error. I really hope I can provide a fix soon.

    BTW I’m running localhost on windows install of Nginx 1.1.7

    Don’t think it’d make any difference but thought I’d mention it just in case!

    Hi all, same problem here.

    Environment: Win7 64 bit with the latest InstantWP. Just installed it, updated WP to the latest one (automatic update), removed all content and other plugins. I activated the debug and it says:

    Notice: add_contextual_help is deprecated since version 3.3! Use get_current_screen()->add_help_tab() instead. in C:\Users\Maki\Siti web\Gianni\InstantWP_4.1\iwpserver\htdocs\wordpress\wp-includes\functions.php on line 3467

    Warning: Cannot modify header information – headers already sent by (output started at C:\Users\Maki\Siti web\Gianni\InstantWP_4.1\iwpserver\htdocs\wordpress\wp-includes\functions.php:3467) in C:\Users\Maki\Siti web\Gianni\InstantWP_4.1\iwpserver\htdocs\wordpress\wp-includes\pluggable.php on line 866

    Hope it helps to reproduce the bug, if I can do anything else just ask.

    Plugin Author Mert Yazicioglu


    These are not related to WordPress Move unfortunately. add_contextual_help function is not used by WordPress Move at all. Check functions.php inside the directory of the theme you are using currently. Most likely the code there is causing these errors.

    I suspected it. Isn’t there a log somewhere?
    BTW I tried Bitnami WordPress Stack and got the same fatal error.

    On the same machine with XAMPP it works (before you ask XAMPP was disabled before trying the others). Actually I think it works, but I’m not sure it’s all ok. I made a backup of a live site and copied the files on my PC then I restored it locally to have a mirror. I expected the plug-in to erase anything else before restoring the backup, but it didn’t. Is that correct?

    Plugin Author Mert Yazicioglu


    Plugin drops each table on your database and recreates it with the new data, one by one.

    Did you create the backup files using the Migrate option of Migration Assistant or the Backup Manager? If you did not create them using the Migrate option with the Change Domain Name section filled in appropriately, then every time you navigate to the local mirror using your browser, you are actually being redirected to the live site.

    I found the problem, my live site uses a different $table_prefix than my local backup, so while the tables were created correctly the site continued to work on the old tables! I suppose this is a particular case, but probably still worth checking that $table_prefix matches.

    I can’t use the Migration Assistant (can’t FTP from the ISP to localhost). So I created a full backup with the Backup Manager and FTPed manually to my hard disk. And of course I was redirected to the live site. 🙂 Anyway I worked around this, but an option to skip the FTP would be nice for those backing up to their hard disks.

    I also noticed that if I set chunk size to 0 I get a backup of some 2200 files! From the docs I expected one single file.
    If I set chunk size to 100 it silently fails. That’s likely a limit of my ISP (stops too heavy resource usage) but some feedback to the user during the backup would be nice.

    Still I can’t understand why InstantWP and Bitnami installations don’t work.

    Some more information –

    I’ve downloaded WordPress move 1.3 from a live site where it installs and works well.

    I’ve installed it on a site on my localhost (Nginx 1.1.7, PHP 5.3.8 WP 3.3.1) and I get the fatal error warning when activated. As previously wp-debug on, provides no further information.

    Just hope that the problem is fixable one way or another!

    Thank you.

    Plugin Author Mert Yazicioglu


    .tartamillo.: It should have created only one backup file when you set it to 0, yes. Will have a look at that, InstantWP and Bitnami. Thanks for the feedback 🙂

    ga-uk: Will do my best to fix it if it is caused by the plugin. Thanks for the details 🙂

    Connecting to… Success!
    Logging in as cortnaab using password… Success!
    Starting uploading files…
    DBBackup-13300078421.sql is being uploaded… Success! is being uploaded…

    Just sits there, no sign of it finishing?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Fatal Error on Activation of WordPress Move’ is closed to new replies.