Support » Plugin: Advanced Menu Manager » Fatal Error on activating

  • Resolved zmrfzn

    (@zmrfzn)


    Warning: require_once(/home/<user>/public_html/wp-content/plugins/advance-menu-manager/includes/classes/class_activator.php): failed to open stream: No such file or directory in /home/<user>/public_html/wp-content/plugins/advance-menu-manager/Advance-Menu-Manager.php on line 66

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor thedotstore

    (@thedotstore)

    Hello @zmrfzn,

    Thanks for reaching out to us.

    We have checkout out at our side with the latest plugin and wordpress but, we can’t facing this type of issue.

    So, can you please create support ticket so your technical team contact you with in 1 to 2 working days.

    Create support ticket

    Thanks,
    Thedotstore team

    The issue is that the filename on Class_Activator.php is capitalised but not in the root plugin file. As soon you change the casing in the filenames this issue is gone!

    I’m getting the same problem so the problem hasn’t been resolved. I see that a workaround has been given but…

    I’ve tried editing line 66 in Advance-Menu-Manager.php to change the file name to Class_Activator.php so that it is the same case as the file in /includes/classes

    I’ve also tried leaving Advance-Menu-Manager.php as-is and changing the case in /includes/classes to match the case in line 66

    Both actions result in the site giving Error 500 which I can only recover from by heading into the file system and deleting the advance-menu-manager directory

    Can @holypoly or the plugin author either describe their actions in a bit more detail or, in the case of the plugin owner, issue an update.

    Thanks
    Russell

    Plugin Contributor thedotstore

    (@thedotstore)

    Hello @holypoly and @argyrg,

    We have resolved this issue in latest version 2.3.

    Please download latest version and let us know still you have any issue.

    Thanks & regards,
    Thedotstore support team.

    holypoly

    (@holypoly)

    That is great! Thanks!

    There is another issue that I had to deal with and that was regarding the stylesheet with the plugin. The style that was included in the plugin did override the core admin stylesheet which is not good. You should take a look at that some time.

    Plugin Contributor thedotstore

    (@thedotstore)

    Hello @holypoly,

    Thanks for not down the issue.

    We will take care your point and update in next upcoming version.

    Thank you.

    Plugin Contributor thedotstore

    (@thedotstore)

    Hello @holypoly,

    Thanks for providing the feedback.

    We have resolved the override the core admin stylesheet issue.

    Please update the plugin with latest version so you can get the updated ADMIN GUI.

    Thank you.

    After update 2.3 to 2.4: Fatal Error on activating, Advance-Menu-Manager.php on line 66…

    Fatal error when upgrading to version 2.4.

    Error:
    Warning: require_once(/home/<user>/public_html/wp-content/plugins/advance-menu-manager/includes/classes/class_admin_page.php): failed to open stream: No such file or directory in /home/<usesr>/public_html/wp-content/plugins/advance-menu-manager/advance-menu-manager.php on line 406

    Fatal error: require_once(): Failed opening required ‘/home/<user>/public_html/wp-content/plugins/advance-menu-manager/includes/classes/class_admin_page.php’ (include_path=’.:/opt/cpanel/ea-php70/root/usr/share/pear’) in /home/<user>/public_html/wp-content/plugins/advance-menu-manager/advance-menu-manager.php on line 406

    Plugin Contributor thedotstore

    (@thedotstore)

    Hello @oaicomm and @zivam ,

    We are sorry for the error that you are getting. We understand your query.

    Please allow us sometime to review it and get back to you with in 1 or 2 days.

    We appreciate you write to us and sharing with us.

    Plugin Contributor thedotstore

    (@thedotstore)

    Hello @oaicomm and @zivam,

    Thanks for the co-operate.

    We have resolve this issue.

    Please click here to check the change log.

    Please update plugin to latest version.

    Thanks,

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.