Support » Plugin: WP Super Cache » Fatal error on 1.5.0

  • After upgrading to 1.4.9 to 1.5.0 this morning, we’re seeing this error on every page (including admin pages):

    Class ‘WP_REST_Controller’ not found in /home/——/public_html/wp-content/plugins/wp-super-cache/rest/class.wp-super-cache-rest-get-settings.php

    We renamed the plugin folder and deleted cache to get the site back up.

    Any help is most appreciated!

    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Damn, 8 mins too late đŸ˜‰
    Same error for me. Renaming the plugin folder should be enough to though.

    I ma receiving the same error with supercache version 1.5.0

    Signed up to report this too (Is there no upvote feature?)

    I got the same error on my WordPress 4.5.9 install. I just renamed the plugin folder until I can update WP.

    Plugin Author Donncha Ă“ Caoimh

    (@donncha)

    What version of WordPress are you using? Please upgrade to WordPress 4.8 if you haven’t yet.

    I’m receiving this error too.

    I got the same error on my WordPress site.

    • This reply was modified 2 years, 8 months ago by ricardoranal.

    @nicolas-cuny and @insomnia88 thank you so much for your tip!
    It really works!

    • This reply was modified 2 years, 8 months ago by ricardoranal.

    same error on 12 of my websites !!

    Fatal error: Class ‘WP_REST_Controller’ not found in /public_html/wp-content/plugins/wp-super-cache/rest/class.wp-super-cache-rest-get-settings.php on line 5

    Updating WP Super Cache to 1.5.1 solved the problem for me, even without updating WordPress.

    • This reply was modified 2 years, 8 months ago by Nicolas Cuny.

    Hello,

    I’m seeing the same error after I did a global update on the plugins. I’m updating to 4.8 now, (currently updating) but have two questions:

    @nicolas-cuny – how where you able to update the WP super-cahce?

    i can’t log into the site (the error shows up when I try to log in. (I have wpmudev and tried to login through there and still get the same error. (I also tried to log into the connected database (hosted at godady) and it too produced the same error.

    ALSO for @nicolas-cuny
    If I rename the plugin folder can you direct me to steps to recover from renaming the folder if/after I resolved the issue?

    Thank-you everyone for the feedback and help.

    Max

    I was having this problem. As suggested in this thread, I SSH-ed into my hosting account, and renamed the wp-content/plugins folder to wp-content/plugins_renamed. I could then access my WordPress site via web browser. I signed into the administrative pages, and updated WordPress to the latest version. Then, I went back to SSH and restored the plugin folder’s original name. Back in WordPress, I could then use the admin pages to update all plugins and themes.

    Problem solved!

    Sure. This is what I did :

    1. log into hosting (FTP or SSH)
    2. go to wp-content/plugins
    3. rename wp-super-cache folder to wp-super-cache.old
    4. log into WP Admin
    5. (you should then receive a warning that plugin WP Super Cache could not be found and has been deactivated)
    6. just go to Plugins > Add new in the sidebar
    7. search for WP Super Cache and install it again from the repository
    8. that’s it !

    Please note that I only renamed the wp-super-cache folder because I knew for sure from analyzing log files that that’s where the problem came from. Otherwise you can rename the whole plugins folder.

    @ibeatty, @nicolas-cuny

    Thanks so much for the help. renaming the super_cache folder brought the site back to life.

    So now I can work from there.

    Thank-you everyone for your help.

    Max

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fatal error on 1.5.0’ is closed to new replies.