Support » Plugin: MailPoet - emails and newsletters in WordPress » Fatal Error Occurs When Trying to Activate the Plugin

  • Resolved 831creative

    (@831creative)


    Trying to activate the installed plugin I am getting the following error:

    Warning: Cannot declare interface Twig_CacheInterface, because the name is already in use in /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/vendor/twig/twig/src/Cache/CacheInterface.php on line 60

    Fatal error: Uncaught TypeError: Argument 1 passed to Twig\Lexer::__construct() must be an instance of Twig\Environment, instance of Twig_Environment given, called in /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/lib/Config/Renderer.php on line 92 and defined in /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/vendor/twig/twig/src/Lexer.php:56 Stack trace: #0 /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/lib/Config/Renderer.php(92): Twig\Lexer->__construct(Object(Twig_Environment), Array) #1 /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/lib/Config/Renderer.php(49): MailPoet\Config\Renderer->setupSyntax() #2 /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/lib/Subscribers/NewSubscriberNotificationMailer.php(39): MailPoet\Config\Renderer->__construct(true, false) #3 /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/generated/FreeCachedContainer.php(637): MailPoet\Subscribers\NewSubscriberNotificationMailer->__construct() #4 /nas/content/live/decomdige in /nas/content/live/decomdigest19/wp-content/plugins/mailpoet/vendor/twig/twig/src/Lexer.php on line 56

    It appears that this is being caused by the plugin itself. Please help me resolve this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi there @831creative,

    Can you try deactivating all your other plugins? Then activate Mailpoet, then re-activate the rest of your plugins and see if it works correctly.

    Thanks!

    Thread Starter 831creative

    (@831creative)

    That worked. Thanks

    Hi. I am having exactly the same problem and have tried the solution described above. Uunfortunately it doesn’t work for me and I am unable to tell which other plugin may be causing the conflict. Is there anything else I can try?

    The website is http://www.wayfarerschorus.com.

    Thanks

    Ian

    Bonjour,
    I am having the same problem and have tried the solution described above. Unfortunately it doesn’t work for me and I am unable to tell which other plugin may be causing the conflict. Is there anything else I can try? Thank you
    Message d’erreur :
    Fatal error: Uncaught TypeError: Argument 1 passed to Twig\Lexer::__construct() must be an instance of Twig\Environment, instance of Twig_Environment given, called in /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/lib/Config/Renderer.php on line 92 and defined in /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/vendor/twig/twig/src/Lexer.php:56 Stack trace: #0 /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/lib/Config/Renderer.php(92): Twig\Lexer->__construct(Object(Twig_Environment), Array) #1 /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/lib/Config/Renderer.php(49): MailPoet\Config\Renderer->setupSyntax() #2 /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/lib/Subscribers/NewSubscriberNotificationMailer.php(39): MailPoet\Config\Renderer->__construct(true, false) #3 /homepages/46/d708135416/htdocs/clickandbuilds/FOH314 in /homepages/46/d708135416/htdocs/clickandbuilds/FOH3147505/wp-content/plugins/mailpoetold/vendor/twig/twig/src/Lexer.php on line 56

    I have restored my website to a working version and then installed the Mailpoet update, with the same result. So the issue seems to be with the latest Mailpoet update rather than any other plugin.

    I’ll stick to the previous version until this is fixed.

    Thanks

    Ian

    Hi

    I also have that problem, but I can´t access to my login site.
    I am getting same error message.

    The website is: http://www.mychallengeclub.com

    When you get that error the way to get back into your site is to rename the plugin file, so that WordPress cannot process it. There may be other ways but that is the one I have found easiest and quickest.

    Same problem here which I’ve notified the plugin developer via email 4 days ago. As there is no solution forthcoming, I simply uninstalled the plugin & moved on to MailerLite. Goodbye MailPoet…forever.

    • This reply was modified 2 years, 2 months ago by webportal.

    Hi
    I get the same issue when trying to activate.
    I’ve de-activated all plug-ins and tried to activate the mailpoet plug-in.
    It worked but I get the following error when going to “Emails”

    Warning: require_once(/home/customer/www/freadomtrack.com/public_html/wp-content/plugins/mailpoet/vendor-prefixed/doctrine/orm/lib/Doctrine/ORM/Mapping/Driver/../Index.php): failed to open stream: No such file or directory in /home/customer/www/freadomtrack.com/public_html/wp-content/plugins/mailpoet/vendor-prefixed/doctrine/orm/lib/Doctrine/ORM/Mapping/Driver/DoctrineAnnotations.php on line 42

    Fatal error: require_once(): Failed opening required ‘/home/customer/www/freadomtrack.com/public_html/wp-content/plugins/mailpoet/vendor-prefixed/doctrine/orm/lib/Doctrine/ORM/Mapping/Driver/../Index.php’ (include_path=’.:/usr/local/php71/pear’) in /home/customer/www/freadomtrack.com/public_html/wp-content/plugins/mailpoet/vendor-prefixed/doctrine/orm/lib/Doctrine/ORM/Mapping/Driver/DoctrineAnnotations.php on line 42

    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal Error Occurs When Trying to Activate the Plugin’ is closed to new replies.