Support » Plugin: Post SMTP Mailer/Email Log » Fatal error. No such file or directory in Postman.php

  • Hi, I updated to 1.8.6 and lost access to my dashboard. I renamed the plugin to post-smtp_old and regained access to the dashboard. I renamed the plugin back to post-smtp and then tried to activate it but received these errors:

    Warning: require_once(Postman-Mail/PostmanContactForm7.php): failed to open stream: No such file or directory in …Postman.php on line 57

    Fatal error: require_once(): Failed opening required ‘Postman-Mail/PostmanContactForm7.php’ (include_path=’.:/opt/cpanel/ea-php56/root/usr/share/pear’) in …Postman.php on line 57

    Is there a file missing from the update or should line 57 be commented out?

    Thank you,
    Paul

    • This topic was modified 6 months, 4 weeks ago by  pah123.
Viewing 9 replies - 1 through 9 (of 9 total)
  • I am having same issue. Here is what i did to resolve until another update is released

    Commented out line 57
    //require_once 'Postman-Mail/PostmanContactForm7.php';
    Commented out line 111
    //new Postsmtp_ContactForm7;

    SMTP is working again and successful test emails sent.

    Hope this helps. I had 30+ sites affected.

    6+ sited affected
    delete plugin is help me 🙁

    Fatal error: require_once(): Failed opening required ‘Postman-Mail/PostmanContactForm7.php’ (include_path=’.:/opt/alt/php70/usr/share/pear’) in /home/*********/public_html/wp-content/plugins/post-smtp/Postman/Postman.php on line 57

    Same here, HTTP Server 500 error. Had to delete the plugin in FTP to get back to wp-admin.

    I have no plans of installing Contact Form 7 so don’t need that.

    • This reply was modified 6 months, 4 weeks ago by  ncsfastaff.

    Broke my site with the same error … Postman.php on line 57. Disabled the plugin to get the site back up by moving it to the “plugins.deactivate” directory

    The same issue broke all my sites using the plugin. Please fix ASAP.

    I had the same issue.

    Had the same issue. Followed ngnly‘s advice and it’s back on.

    For those who are confused. You can either follow @ngnly instructions to edit the plugin or just login to the server with your FTP account and delete the plugin.
    /wp-content/plugins/post-smtp/

    You can download an older version from GitHub while you wait for Yehuda to upload a fixed version.
    Version 1.7.10 https://github.com/yehudah/Post-SMTP/archive/master.zip

    I keep the last 3 versions of any plugin so it was easy to install the previous version. If you have the previous working version 1.8.3 plugin on multiple sites, copy the old version from one of your other sites.

    post-smtp version 1.8.6

    [24-Apr-2018 00:26:17 UTC] PHP Warning:  require_once(Postman-Mail/PostmanContactForm7.php): failed to open stream: No such file or directory in /wp-content/plugins/post-smtp/Postman/Postman.php on line 57
    [24-Apr-2018 00:26:17 UTC] PHP Fatal error:  require_once(): Failed opening required 'Postman-Mail/PostmanContactForm7.php' in /wp-content/plugins/post-smtp/Postman/Postman.php on line 57
    Plugin Author yehudah

    (@yehudah)

    Sorry guys, pushed 1.8.8

    Notice something didn’t refresh here at the repo so I pushed 1.8.8, but is the same 1.8.7

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal error. No such file or directory in Postman.php’ is closed to new replies.