[resolved] Fatal Error Multisite (12 posts)

  1. Rob Land
    Posted 3 years ago #


    I am using a multisite installation on http://www.overzicht.nu, I decided to work with subdomains and this works fine. It was easy to create three working sub-domain sites. E.g. http://kreta.overzicht.nu/

    This morning I wanted to create the fourth domain and this went fine too, until I tried to visit the dashboard of this newly created site. Also accessing the site directly led to a fatal error.

    Check: http://rob.overzicht.nu/ and http://rob.overzicht.nu/wp-admin/

    I am using WP 3.4.1 with RedLine theme and SEO Ultimate and Ultimate TinyMCE plugins. This setup was activ from the beginning and gave no problems with the first three domains.

    I tried to remove rob.overzicht.nu and create another with different name but the error keeps coming.

    On the other domains eveything works as it should.

    Can anyone help me out here?

    Warm regards,
    Rob Land

  2. How did you set up subdomains on the server? Wildcard or manually?

  3. Rob Land
    Posted 3 years ago #

    Hi Mika,

    The sub-domains were setup through Wildcard.


  4. Okay that seems to be working...

    What network activated plugins are you running? Have you added any since the last time you were able to add a site?

  5. Rob Land
    Posted 3 years ago #

    I'm running WP-Statistics, SEO Ultimate, Custom Contactform and Ultimate TinyMCE plugins.

    These were all running from the beginning so I was able to create a new site.

  6. Rob Land
    Posted 3 years ago #

    BTW this is the error that occurs in my browser:

    Fatal error: Call to undefined function wp_get_current_user() in /home/statworx/domains/overzicht.nu/public_html/wp-includes/capabilities.php on line 1203

  7. Did you change your default theme in wp-config?

    There's no reason that should happen, unless a plugin changed (upgraded).

  8. Rob Land
    Posted 3 years ago #

    No I didn't manually change wp-config after initial install.

  9. Well this is a case for the old standbys.

    Turn off all your network activated plugin, even the ones in mu-plugins.

    Make sure that the theme TwentyEleven is assigned to the new site.

  10. Rob Land
    Posted 3 years ago #

    Okay, I turned off everything that didn't came with the WP-package, made TwentyEleven the only theme and added a new site.

    It worked!

    Is it smart to switch on one-by-one the plugins and theme to determine where the problem is?

  11. Yeah, that is very smart :)

  12. Rob Land
    Posted 3 years ago #

    Okay, I will keep you posted when I discover the problem.

    Thanx for the help Mika!

    Regards from a rainy Holland :-(


Topic Closed

This topic has been closed to new replies.

About this Topic