Support » Plugin: WooCommerce » [Fatal error] Moving live site to local server

  • Resolved perrynewman

    (@perrynewman)



    Hello,

    I am trying to move my live site to a localhost server for testing purposes, when initiating the move I encounter a 505 error which I have set WP_DEBUG to true in the wp-config.php file to see what error messages I am facing, I have deactivated all plugins on the site and when activating each plugin one by one I now get a fatal error when activation WooCommerce, the error I get on screen is pasted below.

    Fatal error: Uncaught WC_Data_Exception: Invalid billing email address in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-data.php:745 Stack trace: #0 /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/class-wc-customer.php(983): WC_Data->error(‘customer_invali…’, ‘Invalid billing…’) #1 /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/data-stores/class-wc-customer-data-store-session.php(100): WC_Customer->set_billing_email(‘nfo@localhost’) #2 /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(147): WC_Customer_Data_Store_Session->read(Object(WC_Customer)) #3 /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/class-wc-customer.php(117): WC_Data_Store->read(Object(WC_Customer)) #4 /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/class-woocommerce.php(457): WC_Customer->__construct(1, true) #5 /Applications/MAMP/htdocs/wo in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-data.php on line 745

    Do you know what would be causing this and how I can go about fixing the issue?

    The site works perfectly fine with no problems on the live shared hosting server, it’s only appearing on the local server on my laptop.

    I look forward to your reply.

    Kind regards.

    Perry

Viewing 2 replies - 1 through 2 (of 2 total)
  • A quick question: what version of WooCommerce are you using there?

    Two possibilities:
    1. No email service on localhost, hence the email address is not validated.
    You can install email service on localhost and see if this gets resolved.

    2. In your WooCommerce installation find the file: woocommerce/includes/class-wc-customer.php
    In this file find class WC_Customer, in this class find the line that says:
    ’email’ => ” there may be some value saved there, delete the value and make it empty string.
    Then try adding the plugin.

    3. If all else fails: You can always install a fresh wooCommerce plugin and start from scratch.

    – all the best,

    Plugin Support eri32s98

    (@eri32s98)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved. If you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Fatal error] Moving live site to local server’ is closed to new replies.