Support » Fixing WordPress » FATAL ERROR MESSAGE while updating to new version of WordPress

  • My site and the WordPress dashboard both crashed while updating to the latest version of WordPress (3.4.1). I used the Update Automatically option.

    Here are the error messages:

    Site: http://fitnessvortex.com
    Fatal error: Call to undefined function _prime_post_caches() in /home/content/f/v/s/fvsschone/html/wp-includes/query.php on line 2645

    WordPress Admin: http://fitnessvortex.com/wp-admin/
    Fatal error: Call to undefined function wp_is_mobile() in /home/content/f/v/s/fvsschone/html/wp-admin/index.php on line 22

    Any help is greatly appreciated. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Update manually…
    Re-uploading via FTP all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Should I backup the SQL database first? Not sure about this since the site is currently down. Thanks!

    Should I backup the SQL database first?

    Always advised to back things up before you make changes. 🙂

    Now I’m freaking out. I used this procedure from another post in this forum:
    —–
    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    – resetting the plugins folder by FTP or phpMyAdmin.
    http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F
    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.
    – running the upgrade manually via wp-admin/upgrade.php
    —-
    Now I get this error when trying to login to WordPress:

    http://fitnessvortex.com/wp-admin/
    Warning: require(/home/content/f/v/s/fvsschone/html/wp-includes/class-wp-theme.php) [function.require]: failed to open stream: No such file or directory in /home/content/f/v/s/fvsschone/html/wp-settings.php on line 115

    Fatal error: require() [function.require]: Failed opening required ‘/home/content/f/v/s/fvsschone/html/wp-includes/class-wp-theme.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/f/v/s/fvsschone/html/wp-settings.php on line 115
    ——-
    f/v/s/fvsschone is something I setup with GoDaddy when starting the site. Please help

    Finally, this is issue is resolved. Not sure if I should click the link in this notice at the top of the Dashboard:

    An automated WordPress update has failed to complete – please attempt the update again now.

    Thanks.

    Fatal error: Call to undefined function _prime_post_caches()

    My site and the WordPress dashboard both crashed while updating to the latest version of WordPress (3.4.1). I used the Update Automatically option.

    Here are the error messages:
    Site: http://movies.thamilvalai.com
    Fatal error: Call to undefined function _prime_post_caches() in /home/thamilva/public_html/movies/wp-includes/query.php on line 2645

    Admin is working..

    Please help me immediatly…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘FATAL ERROR MESSAGE while updating to new version of WordPress’ is closed to new replies.