[resolved] Fatal error message when I try to change the language (5 posts)

  1. anneliekatt
    Posted 9 years ago #

    I have today upgraded my wordpress from 2.0.5 to 2.2.1. It is the first time I have upgraded it since I installed it. My webhotel has fantastico so I upgraded it from there, just with one click.
    Now my problem is that my previous posts, and everything else, that is written in my language swedish looks very funny with strange letters instead of the swedish letters.
    I haven´t used any language file before, it worked fine from the start to write in swedish.
    Now I have been reading in the support forums how to change your language. I have downloaded the language file and uploaded it in the langugaes file, and changed the config file and so on, just as I read I should do.
    But when I have edited the config file and uploaded it, and then go to my homepage in my browser, I get this error message:
    "Fatal error: Call to undefined function: wp() in /home/eilenna/public_html/blog/wp-blog-header.php on line 18"

    It doesn´t work no matter how I edit/change the config file, and write my swedish .mo file instead, I still get this error message.
    I have tried to install my backupfile hoping it would help. But the only thing that happened was that there were questionmarks instead of the swedish letters, not ä as it was before after the upgraded. Now I have upgraded again to the latest version and there is ä instead of swedish letters.
    Can anyone help me understad what is wrong and what I can do about it?

  2. moshu
    Posted 9 years ago #

    (of course, you should have read it before - and never trust the "easy automatic" ways...)

  3. anneliekatt
    Posted 9 years ago #

    I have already done that (forgot to write it before), because I found it in the support forums.
    But even if I delete those lines and don´t change the language part, I still get that error message when trying to go to my homepage. I get the same error when I both delete those lines in the config file and change the language.

  4. moshu
    Posted 9 years ago #

    try to re-upload the wp-includes/classes.php file (or a fresh copy of it)

  5. anneliekatt
    Posted 9 years ago #

    I tried that and that didn´t work. But I came up with another idea and that worked!! :)
    I uploaded the wp-config file from my backup! So I replaced the new one with my old one. And that worked!
    oooh I am so happy :)

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic