Support » Plugin: Event Calendar Newsletter » "Fatal error" message after updating plugin

  • Resolved nfichera


    Hello! I’ve been using your plugin for a few months and it’s been working great. Site is Yesterday, I updated it while it was activated, and it crashed my site. I deactivated all the plugins via my ftp, reactivated all of them, and now get this message when I try to activate the newsletter plugin (see below). Let us know how to get this resolved–we love the plugin and would love to continue using it!


    “Plugin could not be activated because it triggered a fatal error.

    Warning: include_once(/home/distrio9/public_html/wp-content/plugins/event-calendar-newsletter/includes/wp-requirements.php): failed to open stream: No such file or directory in /home/distrio9/public_html/wp-content/plugins/event-calendar-newsletter/event-calendar-newsletter.php on line 33

    Warning: include_once(): Failed opening ‘/home/distrio9/public_html/wp-content/plugins/event-calendar-newsletter/includes/wp-requirements.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/distrio9/public_html/wp-content/plugins/event-calendar-newsletter/event-calendar-newsletter.php on line 33

    Fatal error: Class ‘ECN_WP_Requirements’ not found in /home/distrio9/public_html/wp-content/plugins/event-calendar-newsletter/event-calendar-newsletter.php on line 36″

Viewing 1 replies (of 1 total)
  • Plugin Author Brian Hogg



    Yes, a new file was not pushed in with the update, causing the error. If you delete and re-install the plugin (verison 2.4.1), this error should now be resolved as of yesterday evening.

    Sorry for the trouble and let me know if that does the trick!

Viewing 1 replies (of 1 total)
  • The topic ‘"Fatal error" message after updating plugin’ is closed to new replies.